Miscellaneous

In this chapter, you find a collection of useful information for working with VisualApplets.

Command Line Options

VisualApplets offers some command line arguments in order to use VisualApplets, for example, in batch scripts, or for linking the program into a system environment.

The syntax follows the following scheme:

<VISUALAPPLETSINSTALLDIR>\VisualApplets <-COMMAND> <ARGUMENTS>

The commands, together with the expected arguments, are listed in the following table:

Command Line Argument & Meaning

-file

Execute commands stored in a specified Tcl script.

Arguments:

  • Filename of Tcl script (*.tcl)

-compile

Load a specified file and create an applet. The design will be checked against the design rules.

Arguments:

  • Filename of VisualApplets design file (*.va)

  • Filename of resulting applet file (*.hap)

-merge

Merges a microEnable IV applet file with a PixelPlant applet file. A check for suitability of both source applet files will be done.

Arguments:

  • Filename of mother board applet (*.hap)

  • Filename of PixelPlant applet (*.hap)

  • Filename of resulting applet file

-sdk

Generates an SDK Example (C source code) for using the applet with the Framegrabber SDK. The design will be checked against the design rules.

Arguments:

  • Filename of VisualApplets design file (*.va)

  • Filename of PixelPlant applet file (*.hap)

-KeepSyntheseTraceFiles

Additional option when generating a hardware applet. Keeps the intermediate files (created during the build process) for tracing purposes after the build is completed.

<VAFilename>

Load a specified VisualApplets design file.

Used, for example, when assigning *.va files for opening by double click inside the Explorer.

Arguments:

  • Filename of VisualApplets design file (*.va)

Table 14. Command Line Options and According Arguments


Keyboard Shortcuts

Below, you find a list of all shortcuts available in VisualApplets.

Main Program Window

Shortcut Menu Item
Ctrl+N File → New Project
Ctrl+O File → Open Project
Ctrl+S File → Save Project
Ctrl+P File → Print Visible Diagram
Ctrl+Q File → Quit Application
Ctrl+Z Edit → Undo
Ctrl+Shift+Z Edit → Redo
Ctrl+Z Edit → Undo
Ctrl+X Edit → Cut
Ctrl+C Edit → Copy
Ctrl+V Edit → Paste
Del Edit → Delete
F2 Edit → Rename Module
Ctrl+I Design → Add Operator
Mouse 3+ Design → Add Operator
Ctrl+F Design → Search Module
F9 Analysis → Start Simulation
Ctrl+F7 Analysis → Design Rules Check Level 1
Ctrl+F8 Analysis → Design Rules Check Level 2
F7 Build → Build
F5 Build → Start microDisplay
F11 View → Fullscreen
Ctrl++ View → Zoom In Diagram
Ctrl+- View → Zoom Out Diagram
Ctrl+Mouse wheel up View → Zoom In Diagram
Ctrl+Mouse wheel down View → Zoom Out Diagram
Ctrl+Return View → Zoom Reset
Backspace View → Window Up
Ctrl+Space View → Toggle Hand/Selection Tool
Ctrl+Arrow Right Window → Next Diagram
Ctrl+Arrow Left Window → Previous Diagram
Drag+Drop Project files can be dropped on main window.

Table 15. Shortcut List for Main Program Window


Simulation Viewer

Shortcut Menu Item
Ctrl+Q File → Exit Simulation Viewer
Ctrl+C Edit → Copy Image to Clipboard
Del Edit → Remove Selected Images
Ctrl+Del Edit → Remove all Images
Arrow left Navigation → Previous Image
Arrow right Navigation → Next Image
Ctrl++ View → Zoom In
Ctrl+Mouse wheel up View → Zoom In
Ctrl+- View → Zoom Out
Ctrl+Mouse wheel down View → Zoom Out
Ctrl+Mouse 3 View → Normal Size 1:1
F11 View → Full Screen
Ctrl+F View → Fit to Window
Ctrl+T View → Mapped Thumbs
Ctrl+R View → Reset Parameters
Drag+Drop Images can be dropped directly on simulation viewer (source) or simulation source module.

Table 16. Shortcut List for Simulation Viewer


Error Reporting

Even the best developed and tested software might – at times – run into some errors. If you want to help Basler in improving VisualApplets, please report any misbehavior to our support team and describe the situation.

Additional data like the VisualApplets design file (*.va), a description of the system environment like operating system and PC hardware, or your specific VisualApplets system settings is helpful for us when correcting the erroneous misbehavior.

In case of system crashes, a trace file will be generated. This file allows us at Basler to restore the exact situation that led to the crash. This trace file is stored inside a zip-archive which you will find in the installation directory of VisualApplets: <INSTDIR>\bin\bugs\bug*.zip. Please decide if you want to send this supplementary information to Basler or not. Please note that the trace file contains only information that has been entered into VisualApplets. It does not contain any information regarding the computer system VisualApplets was running on.