ユーザーライブラリ

ユーザーライブラリでは、複数回必要になるモジュールの組み合わせをカプセル化し、後で再利用できるように保存することができます。

ユーザーライブラリはいくつでも定義できます。各ユーザーライブラリには、必要な数のユーザーライブラリエレメントを含めることができます。

ユーザーライブラリエレメントには、モジュールとリンクの特定の組み合わせが含まれています。作成後、ライブラリエレメントはライブラリパネル(User Libraryタブ)で使用できるようになり、オペレーターと同様に使用できます。

ユーザーライブラリエレメントは、階層ボックス(「Hierarchical Boxes」を参照)とほぼ同じです。違いは、ユーザーライブラリエレメントが(ユーザー定義の)ユーザーライブラリに保存され、オペレーターライブラリのオペレーターと同様に、さまざまなデザインやプロジェクトに挿入できることです。

ライブラリパネル内のエレメントを持つユーザーライブラリ

図169:ライブラリパネル内のエレメントを持つユーザーライブラリ


ユーザーライブラリエレメントのインスタンスは互いに独立しています。つまり、いずれかのインスタンスに変更を加えても、同じユーザーライブラリエレメントの他のインスタンスには影響しません。

ユーザーライブラリは、 *.val または *.vl ファイルとして保存されます。これらのファイルは特定のプロジェクトの一部ではないため、他のプロジェクトでも使用できます。

ペインの システム設定 VisualAppletsでは、 *.val または *.vl ファイルをシステム上のどこに保存するかを指定できます( 「System Settings」を使用します。

デザインにユーザーライブラリエレメントのインスタンスを挿入した後は、プロジェクトの読み込みやアプレットのビルド(*.hapファイル)に *.val または *.vl ファイルは必要ありません。

新しいユーザーライブラリの作成

新しいユーザーライブラリを作成するには、次の手順に従います。

  1. ライブラリパネルで、User Libraryタブをクリックします。

  2. ユーザーライブラリウィンドウ内で右クリックします。

  3. コンテキストメニューからCreate New User Libraryを選択します。

    (または、メインメニューのLibrary → Create New User Libraryを使用することもできます。)

  4. Create new User Libraryダイアログが開きます。

  5. 新しいユーザーライブラリの名前を入力します。

  6. デフォルトでは、新しいユーザーライブラリは *.val ファイル形式で保存されます。このライブラリをVisualAppletsバージョン3.3.2以前で開く場合は、 Legacy library format (.vl)を選択してください。なお、 *.vl ファイル形式のレガシーユーザーライブラリに保護されたユーザーライブラリエレメントが含まれている場合、このエレメントは保存されず、レガシーファイル形式で開くことはできません。

  7. OKをクリックします。

これで空のユーザーライブラリ(コンテナとして機能)が作成され、ユーザーライブラリ要素を追加できるようになりました。

ユーザーライブラリ名の上にマウスを移動すると、ライブラリが保存されている場所を示すツールチップが表示されます。 *.vl レガシーファイル形式:

ユーザーライブラリエレメントの作成

新しいユーザーライブラリ要素を作成するには、2つの方法があります。次のいずれかを選択できます:

階層型ボックスをユーザーライブラリ要素として保存する

  1. 階層ボックスを右クリックして、モジュールのコンテキストメニューを開きます。

  2. Save to User Libraryを選択します。

    Saveダイアログがポップアップ表示されます:

    階層型ボックスをユーザーライブラリ要素として保存する

    図170:階層ボックスのユーザーライブラリ要素としての保存


  3. 新しい要素を保存するユーザーライブラリを選択します(または、New User Libraryをクリックして新しいライブラリを定義します)。

  4. 新しいユーザーライブラリ要素の名前を(Element Typeの下に)入力します。

  5. オプション:要素に関する情報(バージョン番号、簡単な説明、個別のGUIアイコン、HTMLヘルプファイル形式のドキュメント)を追加する場合:

    1. Detailsをクリックします。新しいダイアログが開きます:

      ドキュメント、バージョン情報、簡単な説明、および/または個別のGUIアイコンの追加

      図171:ドキュメント、バージョン情報、簡単な説明、および/または個別のGUIアイコンの追加


    2. 必要に応じて、ライブラリ要素のバージョン番号を入力します。

    3. 必要に応じて、ライブラリ要素の簡単な説明を入力します。

    4. VisualAppletsのGUI上でライブラリ要素と一緒に表示される特定のアイコンを指定するには、Icon FileフィールドにPNGファイルへのパスを指定するか、フィールドの右側にあるナビゲーションボタンを使用します。

    5. ユーザーライブラリ要素を説明するドキュメントを追加するには、HTML Help Filesの下にあるプラスボタンをクリックし、ドキュメントのテキストが格納されているHTMLファイルに移動します。

      複数のHTMLファイルおよび画像ファイルを指定できます。複数のHTMLファイルを追加した場合、リスト内の最初のHTMLファイルがドキュメントの開始ページになります。開始ページは、ユーザーライブラリ要素のドキュメントとして(情報パネルのHelpタブに)表示されます。追加のファイルには、開始ページからリンクされている画像やその他のHTMLファイルが含まれている場合があります。

      [注] ヘルプファイルの命名と保存

      When you save your user library element later on, all the files you specify here will be copied to the VisualApplets installation directory, sub-directory LibraryCache. The starting page of your documentation (first HTML file in the list) will be renamed and will have the name of the user library element:<elementname>.html

      ライブラリ要素からHTMLファイルのリンクを解除するには、ファイルを選択して削除ボタンをクリックします。HTMLファイルのリンクは解除されますが、ファイルシステムには残ります。

    6. OKを使用して、新しいユーザーライブラリ要素の詳細仕様を確認します。

  6. ユーザーライブラリ要素を保護する場合は、Protectionオプションを選択します。これにより、ユーザーライブラリ要素が「ブラックボックス」になります(要素の保護の詳細については、「ユーザーライブラリ要素の保護」を参照してください)。

  7. Saveをクリックします。

    オプションのPNGファイルとHTMLファイルは、VisualAppletsのインストールディレクトリのサブディレクトリであるLibraryCacheにコピーされます。

    Protectionオプションを有効にしている場合、Protect User Library Elementダイアログボックスが表示されます。

    1. 保護モードのPasswordが有効になっていることを確認してください。

    2. パスワードを入力し、OKをクリックします。

      ライブラリ要素へのパスワードの付与

      図 172. ライブラリ要素へのパスワードの付与


    すべてのUserライブラリとそのコンテンツは、ライブラリパネルで使用できます(The User Interface of VisualAppletsを参照)。User Libraryタブをクリックして、User Libraryウィンドウを表示します。

    選択したアイコンが、ライブラリ要素とともに表示されます。

    個々の要素に関する詳細情報は、ツールチップに表示されます。

    User Library要素のツールチップ情報

    図 173. User Library要素のツールチップ情報


    新しいUser Library要素を選択すると、対応するヘルプ情報がHelpタブの下の情報パネルに表示されます。

    デザインウィンドウ内の表示が変更されます。「HierarchicalBox」の代わりに、User Library要素の名前が表示されます。階層ボックスのアイコンは、ライブラリ要素用に選択したアイコンに置き換えられています。デザイン内のインスタンスの名前(アイコンの下)は変更されていません。

    デザイン内でのUser Library要素の表示

    図 174. デザイン内でのUser Library要素の表示


User Library要素は、後からいつでも変更できます('Editing User Library Elements'のセクションを参照)。ただし、これらの変更は要素のインスタンスには反映されません。必要に応じて、User Library要素のインスタンスを更新するためのさまざまなオプションがあります('Updating Instantiated User Library Elements'のセクションを参照)。

[注] User Library要素の分析

Design Rules Check Level 1を実行できます。

リソース分析、ビルド、シミュレーションは実行できません。

最初から新しいユーザーライブラリ要素を作成する

または、最初から新しいUser Library要素を作成することもできます。User Library要素の定義や変更には、User Library Editorを使用します。

最初から新しいUser Library要素を定義するには:

  1. メインメニューから、Library → Edit User Library → New User Library Elementを選択します。

    これでデザインエディターが閉じます。デザインエディターとともに、作業していたデザインも閉じられます。

    User Libraryエディターが開きます。User Libraryエディターは、通常のデザインエディターと同様に動作します。

  2. 新しいUser Library要素の名前を定義します。

  3. ターゲットハードウェアプラットフォームを選択します。

    (ただし、このプラットフォームは、カメラオペレーターなど、ハードウェアの問題に依存するオペレーターをエレメントに含める場合にのみ関連します。)

  4. OKをクリックします。

  5. OKをクリックすると、ダイアログボックスが開き、エレメントの入力ポートと出力ポートの数を指定する必要があります。これらの数は後から変更できないため、入力リンクと出力リンクの数を正しく指定してください。

    1. 必要な入力ポートの数を指定します。

    2. 必要な出力ポートの数を指定します。

    [注意] 必要な数のリンクを定義する

    後からこれらの数を変更することはできないため、入力リンクと出力リンクの数を正しく指定してください。

  6. OKをクリックしてポートの定義を確認します。

    ユーザーライブラリエディターが開き、指定した入力ポートと出力ポートのみを含む空のエレメントデザインが表示されます。

  7. 必要に応じて、ユーザーライブラリエレメントのデザインを編集します。

  8. 完了したら、メインメニューからFile → Save Asを選択してエレメントを保存します。

    新しいユーザーライブラリエレメントの保存

    図 175: 新しいユーザーライブラリエレメントの保存


  9. 新しいエレメントを保存するユーザーライブラリを選択します(または、New User Libraryをクリックして新しいライブラリを定義します)。

  10. オプション:エレメントに関する情報(バージョン番号、簡単な説明、個別のGUIアイコン、HTMLヘルプファイル形式のドキュメント)を追加する場合:

    1. Detailsをクリックします。新しいダイアログが開きます:

      ドキュメント、バージョン情報、簡単な説明、および/または個別のGUIアイコンの追加

      図 176: ドキュメント、バージョン情報、簡単な説明、および/または個別のGUIアイコンの追加


    2. 必要に応じて、ライブラリエレメントのバージョン番号を入力します。

    3. 必要に応じて、ライブラリエレメントの簡単な説明を入力します。

    4. VisualAppletsのGUI上でライブラリエレメントと一緒に表示する特定のアイコンを指定するには、Icon FileフィールドにPNGファイルのパスを指定するか、フィールドの右側にあるナビゲーションボタンを使用します。

    5. ユーザーライブラリエレメントの説明となるドキュメントを追加するには、HTML Help Filesの下にあるプラスボタンをクリックし、ドキュメントのテキストが保存されているHTMLファイルに移動します。

      複数のHTMLファイルと画像ファイルを指定できます。複数のHTMLファイルを追加した場合、リスト内の最初のHTMLファイルがドキュメントのスタートページになります。スタートページは、ユーザーライブラリエレメントのドキュメントとして(情報パネルのHelpタブに)表示されます。追加のファイルには、スタートページからリンクされている画像やその他のHTMLファイルを含めることができます。

      [注] ヘルプファイルの命名と保存

      When you save your user library element later on, all the files you specify here will be copied to the VisualApplets installation directory, sub-directory LibraryCache. The starting page of your documentation (first HTML file in the list) will be renamed and will have the name of the user library element:<elementname>.html

      ライブラリエレメントからHTMLファイルのリンクを解除するには、エレメントを選択し、削除ボタンをクリックします。HTMLファイルのリンクは解除されますが、ファイルシステムには残ります。

    6. OKをクリックして、新しいユーザーライブラリエレメントの詳細仕様を確認します。

  11. ユーザーライブラリエレメントを保護するには、Protectionオプションを選択します。これにより、ユーザーライブラリエレメントが「ブラックボックス」になります。(エレメントの保護の詳細については、'Protecting User Library Elements'を参照してください。)

    [注] 保護されたエレメントはレガシーファイル形式で保存できません

    ユーザーライブラリを *.vl レガシーファイル形式で保存した場合、保護された要素は保存されません。この場合、保護を解除するか、より新しく推奨される *.val ファイル形式でユーザーライブラリを保存してください。

    レガシーファイル形式を使用すると、VisualAppletsバージョン3.3.2以前でユーザーライブラリを開くことができます。

  12. Saveをクリックします。

    オプションのPNGおよびHTMLファイルは、VisualAppletsのインストールディレクトリのサブディレクトリ LibraryCacheにコピーされます。

    Protectionオプションを有効にした場合は、追加のダイアログProtect User Library Elementが表示されます。

    1. 保護モード Passwordが有効になっていることを確認してください。

    2. パスワードを入力し、OKをクリックします。

      ライブラリ要素へのパスワードの付与

      図177:ライブラリ要素へのパスワードの提供


    すべてのUserライブラリとそのコンテンツは、ライブラリパネルで使用できます(The User Interface of VisualAppletsを参照)。User Libraryタブをクリックして、User Libraryウィンドウを表示します。

    選択したアイコンが、ライブラリ要素とともに表示されます。

    個々の要素に関する詳細情報は、ツールチップに表示されます。

    User Library要素のツールチップ情報

    図178:ユーザーライブラリ要素に関するツールチップ情報


    新しいユーザーライブラリ要素を選択すると、対応するヘルプ情報がHelpタブの下の情報パネルに表示されます。

  13. デザインの作業を続行するには、ユーザーライブラリ要素のデザインとユーザーライブラリエディタを閉じます。メインメニューから、File → Closeを選択します。

    [注意] File->Closeで要素デザインを閉じる

    デザインのタブを閉じるだけでは、要素デザインを閉じたことにはなりません。ユーザーライブラリエディタも閉じる必要があります。

    両方を閉じるには、File → Closeをクリックします。このようにユーザーライブラリ要素のデザイン(およびライブラリエディタ)を閉じて初めて、通常のデザインエディタ、ひいてはアップレットデザイン全体を再び開くことができます。

  14. デザインの作業を続けるには、デザインを開きます。

User Library要素は、後からいつでも変更できます('Editing User Library Elements'のセクションを参照)。ただし、これらの変更は要素のインスタンスには反映されません。必要に応じて、User Library要素のインスタンスを更新するためのさまざまなオプションがあります('Updating Instantiated User Library Elements'のセクションを参照)。

[注] User Library要素の分析

Design Rules Check Level 1を実行できます。

リソース分析、ビルド、シミュレーションは実行できません。

ユーザーライブラリの使用

ユーザーライブラリエレメントのデザインへの挿入

(オペレータの場合と同様に)デザインにシンプルにドラッグ&ドロップすることで、要素のインスタンスを作成できます。

インスタンス化されたモジュールは階層ボックスのように動作しますが、ユーザーライブラリから派生したものであることを認識しています。

エレメントインスタンスのデザインへの適応

デザイン全体に適合するように、ユーザーライブラリ要素のインスタンスを適応させることができます。必要に応じて以下を行います。

  • 個々のオペレータパラメータの変更

  • レイアウトの変更(オペレータやリンクの追加および削除)

[ヒント] リンクプロパティの変更

変更されたリンクプロパティは、ライブラリ要素インスタンスの実装を変更するものではありません。例:ライブラリ要素がParallelism 4で保存されたものの、そのインスタンスがParallelism 8に接続されている場合、これは当然インスタンス内のリンクに影響を与えます。しかし、リンクプロパティの変更によってオペレータパラメータが影響を受けることはないため、これはインスタンスの実装の変更ではありません。

個々のオペレータパラメータの変更、またはレイアウトの変更(オペレータやリンクの追加と削除)のいずれかによって、ユーザーライブラリ要素のインスタンスを変更した後は、そのインスタンスは単なるユーザーライブラリ要素のコピーではなくなります。

どのインスタンスに変更が含まれているかを分かりやすくするために、変更されたユーザーライブラリエレメントのインスタンスにはマークが表示されます:

図 179


ユーザーライブラリエレメントのインスタンスを更新すると(セクション「インスタンス化されたユーザーライブラリエレメントの更新」を参照)、インスタンスに加えられた変更が上書きされるため、これは非常に重要な情報です。変更が含まれているインスタンスに対して自動更新を選択する前に、メリットとデメリットを常に慎重に検討する必要があります。

ユーザーライブラリエレメントの保護

ユーザーライブラリエレメントを保護することができます。 保護を有効にすると、ユーザーライブラリエレメントは「ブラックボックス」になります。 ただし、動的パラメータや、Parametersライブラリのオペレータから参照されているパラメータを含む保護されたエレメントは、実行時にも引き続き表示されます。

[注] 保護されたエレメントはレガシーファイル形式で保存できません

ユーザーライブラリを *.vl レガシーファイル形式では、保護されたエレメントを保存できません。この場合は、保護を解除するか、ユーザーライブラリをより新しく推奨される *.val ファイル形式で保存してください。

レガシーファイル形式を使用すると、VisualAppletsバージョン3.3.2以前でユーザーライブラリを開くことができます。

ユーザーライブラリエレメントを保護する方法には、以下の2つがあります:

  • パスワードによる保護:その後、パスワードを使用してユーザーライブラリエレメントを開き、編集することができます。パスワードを持っていないユーザーは、ユーザーライブラリエレメントで使用されているオペレータを確認することすらできません(ブラックボックス)。

  • 不可逆的な保護:ユーザーライブラリエレメントが永久にブラックボックス化され、自分自身も含めて再度開くことはできません。

パスワードを使用してユーザーライブラリエレメントを保護するには:

  1. エレメントを右クリックします。

  2. コンテキストメニューからProtect User Library Elementを選択します。

    ユーザーライブラリエレメントの保護

    図 180. ユーザーライブラリエレメントの保護


  3. 保護モードPasswordが有効になっていることを確認します。

  4. パスワードを入力します。

    保護されたユーザーライブラリエレメントのパスワード入力

    図 181. 保護されたユーザーライブラリエレメントのパスワード入力


  5. OKをクリックします。

[注意] 「片方向」の不可逆的な保護

保護モードとしてPasswordではなくOne Wayを選択した場合、自分自身も含めてユーザーライブラリエレメントを二度と開き直すことはできません。後からエレメントを拡張する予定がある場合は、代わりに必ず保護モードPasswordを選択してください。または、この保護モードを有効にする前に、エレメントのコピー(階層ボックスまたは保護されていないオペレータとして)を保存しておくこともできます。

ユーザーライブラリエレメントの編集

ユーザーライブラリエレメントに変更を加えることができます。これを行うには、次のいずれかの方法を使用します

  • ライブラリエディタでライブラリエレメント自体を編集する、または

  • 変更されたインスタンスまたは階層ボックスで上書きする。

ただし、これらの変更は自動的には反映されません。ライブラリエレメントのインスタンスに変更を反映させたい場合は、インスタンスを更新する必要があります(セクション「インスタンス化されたユーザーライブラリエレメントの更新」を参照)。

ユーザーライブラリエディターでのユーザーライブラリエレメントの編集

ユーザーライブラリエディタでユーザーライブラリエレメントを編集できます。ユーザーライブラリエディタを開くには:

  1. 現在作業中のデザインを保存します。

  2. ライブラリペインで、User Libraryタブに移動します。

  3. 編集する要素を右クリックします。

  4. 要素のコンテキストメニューから、Editを選択します。

    User Library Editorを開く

    図 182:User Library Editorを開く


これで、デザインエディタが閉じます。デザインエディタとともに、作業していたデザインも閉じられます。

User Library Editorが開きます。User Library Editorは、通常のデザインエディタと同様に動作します。

  1. 変更を加えます。

  2. 変更を保存します。

要素の説明とバージョン番号を編集する場合:

  1. メインメニューから、Library → Element Detailsを選択します。

  2. 編集した要素を保存します。

User Library要素の解析:Design Rules Check Level 1を実行できます。ただし、帯域幅解析、リソース解析、ビルド、およびシミュレーションは実行できません。

[重要] インスタンスの更新

User library要素に変更を加えても、デザイン内のインスタンス化された要素にはこれらの変更は反映されません。ライブラリ要素のインスタンスに要素への変更を反映させるには、インスタンスを更新する必要があります('Updating Instantiated User Library Elements'のセクションを参照してください)。

上書きによるユーザーライブラリエレメントの編集

または、単に上書きしてUser library要素を編集することもできます。その手順は次のとおりです。

  1. 階層ボックスまたはインスタンス化されたUser library要素を、既存のUser library要素の名前で保存します('Saving a Hierarchical Box as a User Library Element'で説明されているとおりです)。

[重要] インスタンスの更新

User library要素に変更を加えても、デザイン内のインスタンス化された要素にはこれらの変更は反映されません。ライブラリ要素のインスタンスに要素への変更を反映させるには、インスタンスを更新する必要があります('Updating Instantiated User Library Elements'のセクションを参照してください)。

以下のセクションでは、インスタンス化されたUser library要素の更新方法に関する情報を提供します。

インスタンス化されたユーザーライブラリエレメントの更新

通常のワークフローでは、User library要素を更新する必要が生じることがあります。ただし、要素に変更を加えても、その要素のインスタンスには影響しません。デザイン内の要素のインスタンスを更新するには、手動で変更を追加するか、VisualAppletsが提供する2つの更新メカニズムのいずれかを使用します(下記を参照)。

手動での更新

変更した要素のインスタンスを手動で更新することにした場合は、デザイン内でその要素の複数のインスタンスを選択し、1つのステップで同時にすべて変更することができます。

[注意] 階層の更新はありません

User library要素の階層更新はサポートされていません。更新のために階層の複数のモジュールを選択した場合、階層の最も上位のモジュールのみが更新されます。

クイックアップデートによるモジュールの置き換え

Quick Update機能を使用して、デザイン内のUser library要素のインスタンスを更新できます。

[注意] 更新するとインスタンス内の変更が上書きされます

User library要素のインスタンスを更新すると、インスタンスに加えられたすべての変更(パラメータ設定、またはオペレータの追加/削除)が上書きされます。変更が含まれるインスタンスに対して自動更新を選択する前に、メリットとデメリットを常に慎重に検討する必要があります。

変更が含まれているインスタンスを把握できるように、ライブラリ要素の変更されたインスタンスにはマークが表示されます:

Quick Updateを介してライブラリ要素のインスタンスを更新するには:

  1. 更新するインスタンスを選択します。

  2. メインメニューから、Library → Quick Update from User Libraryを選択します。

要素の選択されたインスタンスは、ライブラリ内の要素に行った変更を反映した新しいインスタンスに置き換えられます。

Quick Updateは、更新するインスタンスが、編集されたユーザーライブラリ要素と同じ数の入力ポートおよび出力ポートを持っている場合にのみ実行可能です。ユーザーライブラリ要素タイプAのインスタンスをユーザーライブラリ要素タイプBのインスタンスに置き換えるためにQuick Updateを使用することはできません。

Quick Updateを使用すると、要素の複数のインスタンスを一度に更新できます:

  1. Ctrlキーを押したまま、更新するすべてのインスタンスを選択します。

  2. メインメニューから、Library → Quick Update from User Libraryを選択します。

    要素の選択されたすべてのインスタンスが新しいインスタンスに置き換えられます。

Update from User Libraryを介したインスタンスの置き換え

このオプションを選択した場合、置き換え対象のインスタンスは、更新元のライブラリ要素と同じタイプである必要はありません。そのため、このオプションを使用して、ユーザーライブラリ要素または階層ボックスのインスタンスを別のユーザーライブラリ要素のインスタンスに置き換えることができます。たとえば、(「Quick Update」オプションとは異なり)ユーザーライブラリ要素タイプAのインスタンスをユーザーライブラリ要素タイプBのインスタンスに置き換えることができます。ただし、Update from User Libraryについても、置き換え対象のインスタンスが、置き換え先のユーザーライブラリ要素と同じ数の入力および出力ポートを持っている場合にのみ可能です。

要素の1つまたは複数のインスタンスを別のユーザーライブラリ要素のインスタンスに置き換えるには:

  1. 置き換えを行うモジュールを選択します(Ctrlキーを押しながら)。

  2. メインメニューから、Library → Update from User Libraryを選択します。

    ダイアログウィンドウUpdate User Library Elementsが開きます。左側のパネルには更新用に選択したモジュールが表示され、右側のパネルにはユーザーライブラリが表示されます。

    インスタンスの置き換え

    図183. インスタンスの置き換え


  3. 右側のパネルで、必要なユーザーライブラリ要素を選択します。左側のパネルでは、希望通りに置き換え可能なすべてのモジュールが緑色でハイライト表示されます(そうならない場合は、入力と出力の数が一致しているか確認してください)。

  4. Replace Modulesをクリックします。

    ノード数が一致するリスト内のすべてのモジュールが、新しいユーザーライブラリ要素のインスタンスに即座に置き換えられます。

上記の例:2つのケースで入力と出力の数が一致していません。モジュール28には1つの入力ポートと1つの出力ポートしかありませんが、USRLibraryELement5には3つの入力と3つの出力があります。モジュール32、31、および33はUSRLibraryELement5とまったく同じ数の入力ポートおよび出力ポートを持っているため、USRLibraryELement5への置き換えが可能です。

ユーザーライブラリウムジュールの階層ボックスへの変換

要素インスタンスとユーザーライブラリのリンクを解除すると便利な場合があります。これを行うには、ユーザーライブラリ要素のインスタンスを階層ボックスに変換します。

  1. デザイン内で変換するモジュールを選択します(複数のモジュールを変換する場合は、Ctrlキーを押しながら変換するすべてのモジュールを選択します)。

  2. メインメニューから、Library → Change to Hierarchical Boxを選択します。

選択したすべてのモジュールが完全に独立した階層ボックスに即座に変換されます。

提供されるユーザーライブラリ

VisualAppletsの納品物には、2つのユーザーライブラリが含まれています。

  • JPEG_Color

  • imaFlex_CXP12_Tools

  • imaFlex_CXP12_Tools_Advanced

これらの納品されたユーザーライブラリが表示されない場合は、User Libraryパネルを右クリックし、開いたコンテキストメニューからRescan User Library Directoryを選択します。

するとVisualAppletsにより、System Settings → Path Settings → Libraries/Path for storage of user librariesで指定されたディレクトリにあるライブラリが開きます。

JPEG_Color User Library

JPEG_Colorユーザーライブラリには、以下の要素が含まれています。

  • JPEGEncoder_Color_800MPs_VCX:このユーザーライブラリエレメントを使用すると、8ビットカラー画像をJPEG画像に変換できます。JPEG_Encoder_Color_800MPs_VCXはCXPx2フレームグラバー用で、160 MHzのクロックレートで800 MP/sの帯域幅を提供します。入力 Parallelismは8です。

  • JPEGEncoder_Color_1500MPs_VCX:このユーザーライブラリエレメントを使用すると、8ビットカラー画像をJPEG画像に変換できます。JPEG_Encoder_Color_1500MPs_VCXはCXPx2フレームグラバー用で、160 MHzのクロックレートで1200 MP/sの帯域幅を提供します。入力 Parallelismは8です。

  • JPEGEncoder_Color_2500MPs_VCX:このユーザーライブラリエレメントを使用すると、8ビットカラー画像をJPEG画像に変換できます。JPEG_Encoder_Color_2500MPs_VCXはCXPx4フレームグラバー用で、160 MHzのクロックレートで2400 MP/sの帯域幅を提供します。入力 Parallelismは16です。

  • JPEGEncoder_Color_300MPs_VCL:このユーザーライブラリエレメントを使用すると、8ビットカラー画像をJPEG画像に変換できます。JPEG_Encoder_Color_300MPs_VCLはCamera Link (CL) フレームグラバー用で、300 MP/sの帯域幅を提供します。入力 Parallelismは4です。

  • JPEGEncoder_Color_600MPs_VCL:このユーザーライブラリエレメントを使用すると、8ビットカラー画像をJPEG画像に変換できます。JPEG_Encoder_Color_600MPs_VCLはCamera Link (CL) フレームグラバー用で、155 MHzのクロックレートで600 MP/sの帯域幅を提供します。入力 Parallelismは4です。

  • JPEGEncoder_Color_850MPs_VCL:このユーザーライブラリエレメントを使用すると、8ビットカラー画像をJPEG画像に変換できます。JPEG_Encoder_Color_850MPs_VCLはCamera Link (CL) フレームグラバー用で、170 MHzのクロックレートで850 MP/sの帯域幅を提供します。入力 Parallelismは8です。

ユーザーライブラリエレメントの詳細なドキュメントは、VisualAppletsインストールのHelpパネルにあります。

imaFlex_CXP12_Tools User Library

[注] imaFlex_CXP12_Tools_Advanced User Libraryの使用を推奨

imaFlex_CXP12_Toolsユーザーライブラリは、下位互換性のためにのみ提供されています。可能な場合は、代わりにimaFlex_CXP12_Tools_Advancedユーザーライブラリを使用してください。

imaFlex_CXP12_Toolsユーザーライブラリには、以下の要素が含まれています。

  • ImageBufferMultiRoI:このオペレーターは、バッファリングされた画像ごとに複数の関心領域(ROI)をサポートします。imaFlexプラットフォーム用ツールエレメントとしてのユーザーライブラリエレメントImageBufferMultiRoIは、imaFlexプラットフォームではサポートされていないVisualApplets標準オペレーターImageBufferMultiRoIと同じ機能を提供します。

  • ImageBufferMultiRoIDyn:このオペレーターは、バッファリングされた画像ごとに複数の動的な関心領域(ROI)をサポートします。imaFlexプラットフォーム用ツールエレメントとしてのユーザーライブラリエレメントImageBufferMultiRoIDynは、imaFlexプラットフォームではサポートされていないVisualApplets標準オペレーターImageBufferMultiRoIDynと同じ機能を提供します。

imaFlex_CXP12_Tools_Advanced User Library

imaFlex_CXP12_Tools_Advancedユーザーライブラリには、以下の要素が含まれています。

  • FrameBufferMultiRoi:このオペレーターは、バッファリングされた画像ごとに複数の関心領域(ROI)をサポートします。imaFlexプラットフォーム用ツールエレメントとしてのユーザーライブラリエレメントFrameBufferMultiRoiは、imaFlex CXP-12プラットフォームではサポートされていないVisualApplets標準オペレーターImageBufferMultiRoIと同じ機能を提供します。

  • JPEG_Encoder_Color_iF_Penta:JPEG_Encoder_Color_iF_Pentaを使用すると、8ビットカラー画像をJPEG画像に変換できます。

  • JPEG_Encoder_Color_iF:JPEG_Encoder_Color_iFを使用すると、8ビットカラー画像をJPEG画像に変換できます。

ユーザーライブラリエレメントの詳細なドキュメントは、VisualAppletsインストールのHelpパネルにあります。また、ユーザーライブラリエレメントの使用方法を示すサンプルも用意されています。'Basic Acquisition Examples for Cameras for CoaXPress 12 imaFlex Frame Grabber'を参照してください。