メインプログラムウィンドウ

VisualApplets アプレット設計のためのグラフィカルユーザーインターフェースを提供します。スクリプトやプログラミングコードの編集は不要です。ユーザーインターフェースは非常にシンプルで、ユーザーが簡単に習得できるよう特別に設計されています。プログラミングの専門知識は一切必要ありません。

のVisualApplets メインプログラムウィンドウは、いくつかのバーとパネルで構成されています。

メインプログラムウィンドウ

図11. メインプログラムウィンドウ


メインメニューバーからプログラムの機能に直接アクセスできます。ツールバーボタンを使用して、重要な機能にすばやくアクセスできます。ツールバーアイコンのサイズは、 [設定] → [システム設定] → [共通]で変更できます。

3つのパネルはそれぞれ異なる情報と可能性を提供します。

  • デザインパネル: デザインパネルには、 VisualApplets プロジェクトでは、常にメインのデザインウィンドウが1つありますが、プロジェクトの構造によっては、複数のサブウィンドウを使用することもあります。ウィンドウメニューでは、複数の表示形式(タイル表示、カスケード表示、タブ表示)を選択できます。ウィンドウ→ダイアグラムWindows ( Ctrl + F8 )のメニュー項目を使用すると、現在作業しているデザインダイアグラムウィンドウを簡単に選択できます。

  • 情報パネル:メインプログラムウィンドウのデフォルト設定では、情報パネルは常に表示されます。タブ表示でさまざまな情報ウィンドウが表示されます。

    • プロジェクト情報

    • モジュール情報

    • パラメータ情報

    • DRCログ

    • ビルドログ

    • ヘルプ

    (各情報ウィンドウの詳細については、下記をご覧ください。)

  • ライブラリパネル:メインプログラムウィンドウのデフォルト設定では、ライブラリパネルは常に表示されます。タブ表示で3つのライブラリウィンドウが提供されます。

    • オペレーターライブラリ: オペレーターライブラリは、以下のサブライブラリの集合です。 VisualApplets 演算子、すなわち個々の画像処理関数。

    • ユーザーライブラリ:ユーザーライブラリには、ユーザーが定義した演算子の組み合わせ(階層構造のボックス)を含むカスタムライブラリを含めることができます。詳細については、 「ユーザーライブラリ」を参照してください。

    • カスタムライブラリ:オペレーターをカスタムライブラリにインポートするには、エキスパートライセンスまたはVisualApplets 4ライセンスが必要です。

[ヒント] 特定のオペレーター

演算子ライブラリに表示される演算子の中には、現在設計しているプラ​​ットフォームでは利用できないものがあります。選択したプラットフォームで利用できない演算子は、グレー表示されます。

現在選択されている対象ハードウェアプラットフォームでは、オペレーターが利用できません。

図12. 現在選択されているターゲットハードウェアプラットフォームでは、オペレーターが利用できません。


情報パネルのウィンドウ

プロジェクト情報

プロジェクト情報ウィンドウには、現在のプロジェクトに関する情報が要約されて表示されます。

プロジェクト情報

図13. プロジェクト情報


以下の情報が提供されています。

  • 名前:プロジェクト名(=ファイル名)

  • 作成日:作成日

  • 最終更新日:最終更新日

  • バージョン:プロジェクトのバージョン番号。この項目は、 [デザイン] → [プロジェクトの詳細] メニューから編集できます( 「プロジェクトのプロパティ」を参照)。

  • 説明:プロジェクトに関する口頭での説明。この項目は、 「デザイン」 → 「プロジェクトの詳細」メニューから編集できます( 「プロジェクトのプロパティ」を参照)。

  • タイプ:ターゲットハードウェアで現在使用されているFPGAタイプを表示します( 「ターゲットハードウェアのポーティング」を参照)。

  • Target Runtime:ターゲットランタイムを表示します(「Target Runtime」を参照)

  • Design Rules Check Level 1:検出されたエラーまたは正常な処理結果を示します (「Design Rules Check」を参照)

  • Hardware Applet:ハードウェアアプレットの存在を示します。 VisualAppletsが事前にプロジェクトのHAPファイルを生成している場合、このエントリにチェックが入ります。

  • Resources:リソース推定の結果を表示します。「FPGA Resource Estimation」も参照してください。

  • System:検出されたXilinxのバージョン、利用可能な Framegrabber SDKのバージョン、およびFramegrabber SDKのインストールディレクトリを表示します。 この情報は、VisualAppletsによるHAPのビルドおよび最終的なHAP出力に使用されます。 詳細については、「Build」を参照してください。

モジュール情報

Module Infoウィンドウには、プロジェクトで使用されているすべてのモジュールのリストが表示されます(ウィンドウの入力フィールドが空の場合)。 リストはプロジェクトの階層構造によって整理されています。

モジュール検索

図14:モジュール検索


Module Infoウィンドウでは、特定のモジュールやモジュールタイプを簡単に検索できます。これは大規模なデザインを扱う際に 非常に便利です。 検索を開始する前に、フィルター設定を定義する必要があります。

  • モジュールに付けた個別の名前で検索する場合は、「Names」を有効にします。

  • モジュールタイプ(現在検索しているインスタンスのオペレータの名前)で 検索する場合は、「Types」を有効にします。

モジュール検索

図15:モジュール検索


検索文字列を入力できるようになります。名前の一部を入力するだけでも十分です。 Module Infoウィンドウにリストされているモジュールのいずれかをクリックすると、対応するデザインウィンドウが(デザインパネル内で)フォーカスされ、 該当するモジュールが選択されてハイライト表示されます。

パラメータ情報

Parameter Infoビューには、アクティブなデザインのすべてのパラメータとそのオペレータが表示されます。 また、Parameter Infoビューでパラメータを編集することもできます。

パラメータ情報

図16:Parameter Info


Parameter Infoビューには、パラメータ、パラメータ値、またはオペレータ名を検索できる検索機能が用意されています。 Runtime Parameter Onlyフィルターを使用すると、動的パラメータ、つまりランタイム中に編集できるパラメータのみを表示できます。

DRCログ

DRC Logウィンドウには、最後のDesign Rules Checkの結果が表示されます。 警告/エラーメッセージの下にリストされているモジュール名のいずれかをクリックすると、対応するデザインウィンドウが (デザインパネル内で)フォーカスされ、 該当するモジュールが選択されてハイライト表示されます。

DRCログ情報

図17:DRCログ情報


ビルドログ

Build Logウィンドウには、最後のBuildの結果が表示されます。

ビルドログ情報

図18:ビルドログ情報


ヘルプ

Helpウィンドウでは、個々のオペレータに関するコンテキスト依存のヘルプを利用できます。

コンテキスト依存のヘルプを開くには、次のいずれかの操作を行います。

  1. デザイン内で情報を取得したいオペレータを直接選択し、F1を押して、Helpウィンドウに関連情報を開いて表示します。

  2. 演算子ライブラリウィンドウから演算子を選択してください。ヘルプウィンドウには、常に現在選択されている演算子に関するヘルプが表示されます。

例:MergeKernel オペレーターに関する情報の表示

図19. 例:MergeKernelオペレータの情報表示


他のウィンドウでF1キーを押すか、ヘルプボタンをクリックすると、現在選択されているウィンドウまたは機能に関するコンテキストに応じたユーザーマニュアルヘルプが開きます。もちろん、このユーザーマニュアルから直接オペレーターヘルプにアクセスすることもできます。詳しくは「オペレーターリファレンス」をご覧ください。

ライブラリパネルのウィンドウ

ライブラリパネルには、オペレーターライブラリウィンドウ、ユーザーライブラリウィンドウ、カスタムライブラリウィンドウがタブ表示で表示されます。

すべてのライブラリ(演算子ライブラリ、ユーザーライブラリ、カスタムライブラリ、およびそれらのサブライブラリすべて)はツリー構造で構成されています。各ライブラリには演算子が含まれています。

構造の表示方法は、「ツリー」、「リスト」、「アイコン」のいずれかを選択することで変更できます。

オペレーターライブラリが表示されたライブラリパネル

図20. オペレーターライブラリが表示されたライブラリパネル


検索フィールドに検索文字列を入力すると、必要なオペレーターのみを表示するようにリストを絞り込むことができます。たとえば、 「カメラ」と入力すると、名前に「カメラ」を含むすべてのオペレーターが表示されます。

オペレーター ライブラリ

オペレータライブラリは、以下のサブライブラリの集合です。 VisualApplets 演算子、すなわち個々の画像処理関数。

オペレーターライブラリウィンドウでオペレーター名をクリックし、情報パネルの「ヘルプ」タブをクリックすると、各オペレーターの詳細情報を取得できます。

オペレーターライブラリが表示されたライブラリパネル

図21. オペレーターライブラリが表示されたライブラリパネル


図に新しい演算子を追加する方法については、 「演算子の挿入」を参照してください。すべての演算子の詳細な説明は、 「演算子リファレンス」に記載されています。

User Library

ユーザーライブラリには、ユーザーが定義した演算子の組み合わせ(階層構造のボックス)を含むカスタムライブラリを追加できます。詳細については、 「ユーザーライブラリ」を参照してください。

カスタム ライブラリ

カスタムライブラリに演算子をインポートするには、エキスパートライセンスまたはVisualApplets 4ライセンスが必要です。

メインプログラムウィンドウの調整

メインプログラムウィンドウをカスタマイズするためのさまざまなオプションがありますVisualApplets お客様の個人的な好みに合わせて:

ツールバーのカスタマイズ

ツールバーはドラッグ&ドロップで並べ替えたり、右クリックで追加/削除したりできます。

メインプログラムウィンドウのデフォルト設定の復元

ウィンドウやツールバーを意図しない配置にしてしまった場合は、以下の手順でデフォルト設定に戻すことができます。 ウィンドウ → ドックをリセットWindows ( Ctrl + O )または対応するアイコンをクリック 表示ツールバーにあります。

[File] -> [Recent Designs]に表示されるファイル数

ファイル内 →最新デザインVisualApplets 最近オープンしたお店のリストを提供しますVisualApplets ファイル(*.va)。表示されるファイルの実際の数を設定できます。

最近開いたファイルをいくつ表示するかを設定するには:

  1. メニューの Settings → System settings に移動し、カテゴリ Common を選択します。

  2. Recent designs で、表示するファイルの数(最大24個)を設定します。

  3. Ok で確定します。

最近使用したデザインの表示数の設定

図 22: 最近使用したデザインの表示数の設定