Framegrabber SDKを使用したCXPラインスキャンカメラとフレームグラバーの設定#
要件と可能なトポロジの詳細については、General Informationを参照してください。
Framegrabber SDKのインストール#
管理者権限が必要です
Framegrabber SDKをインストールするには、コンピューターの管理者権限が必要です。
Basler racer 2カメラで使用するFramegrabber SDKをインストールするには、以下の手順に従います。
- Framegrabber SDKバージョン5.11.2以降をダウンロードします。
- インストーラーを起動し、インストールを進めます。
- Select Componentsダイアログで、Full installationを選択し、コンポーネントリストでGenTL Producerが選択されていることを確認します。

詳細なインストール手順については、Basler製品ドキュメントのInstalling the Framegrabber SDKトピックを参照してください。
microDisplay Xの第一歩#
-
最初の一連の画像を表示するには、microDisplay Xを開きます。
-
Basler racer 2カメラでの画像取得を簡素化する基本設定をいくつか行います。
- 以下を開きます: ツール > 設定 > Acquisition、 Number of Buffers を
100これにより、取得した画像を閲覧できるようになります。これはカメラのキャリブレーションに非常に便利です。 -
パラメーターを Acquisition Timeout を高めの値(例:
1000 s)に設定します。これはトリガーの設定に必須であり、タイムアウトの発生を防ぎます。
-
Tools > Settings > Discoveryの順に選択し、Autoconnect discovered camerasチェックボックスをオンにします。

- 以下を開きます: ツール > 設定 > Acquisition、 Number of Buffers を
-
microDisplay Xでアプレットをロードします。お使いのセットアップに必要なアプレットを確認するには、Possible Topologiesを参照してください。

-
アプレット名をダブルクリックします。これで、フレームグラバーのFPGAがアプレットで設定されます。
-
Autoconnect discovered camerasを選択しているため、カメラが接続されているはずです:

-
Applet LayoutペインでDMA 0またはCam 0をクリックすると、カメラとフレームグラバーまたはインターフェイスカードのパラメータを切り替えることができます。1台または複数のフレームグラバーやインターフェイスカードに複数のカメラを接続している場合は、ここでカメラとDMAチャンネルを選択できます。
- 必要に応じてカメラとフレームグラバーまたはインターフェイスカードを設定します。
-
フレームグラバーまたはインターフェイスカードの重要なパラメータは、カメラの設定と一致している必要があります。それらは以下の通りです:
- CoaXPress > Pixel Format
- ROI > Width
- ROI > Heightで、希望する画像の高さを指定します。このパラメータ値は、出力画像のカメラライン数を定義します。

-
画像acquisitionを開始するには、 Acquisition Channel で Viewing ペインに切り替え、
Play ボタン。 -
microDisplayXはフレームグラバーのROI設定をサポートします。ラインスキャンカメラの場合は、Ignoreをクリックします。

カメラとフレームグラバーまたはインターフェイスカードがfree run modeになっている限り、カメラ画像が表示されます。

CoaXPressライン・トリガーの使用#
CoaXPressライン トリガーを使用するには、カメラをCoaXPressトリガーモードに設定し、カメラとフレームグラバーまたはインターフェイスカードを次のように設定します:
パラメータを設定する前に画像acquisitionを停止する
パラメータ設定を変更する前に、画像acquisitionを停止する必要があります。停止しないと、一部のパラメータを編集できません。
- Applet Layoutペインで、Cam 0を選択します。
-
Parameter SelectionペインのAcquisition Controlで、次のパラメータを設定します。
Trigger Mode=OnTrigger Source=Cxp Trigger 0

デフォルトでは、フレームグラバーは200 µsの周期を持つ内部ジェネレーターを使用します。ソースを変更する場合、または シャフトエンコーダーを使用する場合は、 DMA 0 で Applet Layout ペインを選択し、ハードウェア設定に合わせて Line Trigger / ExSync パラメータを設定します。 
パラメータの詳細については、imaFlex CXP-12 Quad、imaWorx CXP-12 Quad、およびCXP-12 Interface Cardsのアプレットマニュアルを参照してください。
Exposure Modesについて Trigger Width および Trigger Controlled#
外部信号でExposure Timeを制御するには、2つのExposure Modeを使用できます。 Trigger Width および Trigger Controlled.
- 使用
Trigger Widthトリガー信号をカメラのI/Oに直接接続する場合。 - 使用
Trigger ControlledCXPトリガーパケットを使用し、トリガーがカメラ経由で送信される場合。
Exposure Mode Trigger Width#
Exposure Mode Trigger Widthを使用するには、カメラで次のパラメータを設定する必要があります。
- このExposure Modeに切り替えるには、カメラパラメータを次のように設定します
Exposure Mode=Trigger Width. - トリガーを設定するには、次のパラメータを設定します。
Trigger Selector=Line StartTrigger Mode=OnTrigger Sourceトリガーを接続したI/O(例:)に設定します。Line1.- 反転信号がある場合は、オプションで次のように設定できます
Trigger Activation=Falling Edge.
Exposure Mode Trigger Widthでは、カメラはCXP経由ではなく、I/Oからのトリガー信号を直接使用します。そのため、Exposure Modeを選択した場合、フレームグラバーのトリガーパラメータを設定する必要はありません。 Trigger Width.

Exposure Mode Trigger Controlled#
Exposure Mode Trigger Controlledを使用するには、カメラで次のパラメータを設定する必要があります。
- このExposure Modeに切り替えるには、カメラパラメータを次のように設定します
Exposure Mode=Trigger Controlled. -
トリガーを設定するには、以下のパラメーターを設定します。これにより、CoaXPressトリガーによって露出の開始と終了が行われます。
Trigger Selector=Exposure StartTrigger Mode=OnTrigger Source=Cxp Trigger 0.

Trigger Selector=Exposure EndTrigger Mode=OnTrigger Source=Cxp Trigger 1.

次に、フレームグラバーを設定して Cxp Trigger 0 および Cxp Trigger 1 トリガーパケットを生成する必要があります。次の3つのオプションがあります。
- デフォルトでは、内部ジェネレーターが使用されます。

- 変更すると、
LineTriggerModeパラメータをAsync Gated Trigger、I/O信号を使用して露出時間を制御できます。
- または、I/O信号を直接バイパスして
CXP Link Trigger 0およびCXP Link Trigger 1に送り、露出の開始と終了を制御できます。
画像の検査#
microDisplay Xには、取得した画像を確認するためのいくつかの方法が用意されています。カメラのキャリブレーションを行う際には、以下の項目が役立ちます。
- Line Histogramビュー
- Line Profileビュー
- 取得した画像シーケンスを順に切り替えて表示する
- ピクセル値の取得または各ピクセルの拡大表示
- 現在の画像または画像シーケンスの保存
詳細については、Basler製品ドキュメントのExamining Imagesトピックを参照してください。
SDKコードのコピー#
設定をSDKプログラムにコピーするには、任意のパラメータのDetailsを選択し、SDKコードをコピーします。

または、microDisplay Xで設定ファイルを保存し、SDKプログラムに読み込ませることもできます。詳細については、Basler製品ドキュメントのSaving Applet Configurationトピックを参照してください。
GenTLを使用する場合も、同様のパラメーター設定に従います。GenTL Producerは%GENICAM_GENTL64_PATH%ディレクトリにあります。