コンテンツにスキップ
ステージングサーバー
開発サーバー

カメラキャリブレーション#

このトピックでは、キャリブレーションが必要な理由と、工場出荷時のキャリブレーションが破損した場合にカメラをキャリブレーションする方法について説明します。

カメラを測定器として使用するには、焦点距離、レンズの歪み、カメラ間の関係などのカメラパラメーターを正確に把握する必要があります。これらのパラメーターはキャリブレーションによって決定され、画像補正に使用されます。これは、その後のすべての画像処理の基礎となります。Stereo aceカメラは、カメラのキャリブレーションに基づいて画像を自動的に補正します。

Stereo aceカメラは製造時にキャリブレーションされます。Stereo aceカメラに強い機械的負荷(落下など)が加わった場合、再キャリブレーションが必要になることがあります。再キャリブレーションが必要な兆候として、カメラが突然3Dデータを出力しなくなることが挙げられます。

セルフキャリブレーション#

Stereo aceカメラには、バックグラウンドで低頻度で実行されるセルフキャリブレーションモードがあります。このモードでは、カメラは2つの補正された画像内のラインの整列状態を監視します。カメラの落下などの機械的衝撃により、位置ずれが発生する場合があります。重大な位置ずれが検出された場合は、自動的に修正されます。

セルフキャリブレーションを有効にするには、次のように設定します。 BslSelfCalibration パラメータを On.

の値は、 BslSelfCalibrationUpdateCounter パラメーターは、自動修正が行われるたびに増加します。カメラを手動で再キャリブレーションした後は、にリセットされます。 0.

Stereo aceカメラに機械的衝撃が加わらないなど、通常の条件下では、セルフキャリブレーションが実行されることはありません。セルフキャリブレーションにより、位置ずれが検出されても自動的に修正されるため、Stereo aceカメラは通常通り動作し続けることができます。ただし、次のような場合は、カメラを手動で再キャリブレーションすることをBaslerはお勧めします。 BslSelfCalibrationUpdateCounter パラメータ 0.

手動キャリブレーション#

手動キャリブレーション中には、さまざまな姿勢でキャリブレーショングリッドを検出させる必要があります。キャリブレーショングリッドを持つ際は、グリッドのすべての黒い正方形が両方のカメラ画像に完全に表示され、遮られていないことを確認してください。正しく検出された正方形には、緑色のチェックマークが付きます。適切なキャリブレーションを確保するため、すべての黒い正方形が正しく検出される必要があります。一部の正方形が全く検出されない場合や、ごく短時間しか検出されない場合は、照明条件が悪いことや、グリッドが破損していることが原因である可能性があります。キャリブレーショングリッドの過露出部分にある正方形は赤色で強調表示されます。この場合、照明条件または露出設定を調整する必要があります。キャリブレーショングリッドの周囲にある太い緑色の枠は、両方のカメラ画像で正しく検出されたことを示しています。

キャリブレーショングリッドをカメラの前にかざし、グリッドのすべての黒い正方形が両方のカメラ画像に完全に表示され、遮られていないことを確認します。正しく検出された正方形には、緑色のチェックマークが付きます。適切なキャリブレーションを確保するため、すべての黒い正方形が正しく検出される必要があります。一部の正方形がごく短時間しか表示されない場合や、全く検出されない場合は、照明条件が悪いことや、グリッドが破損していることが原因である可能性があります。キャリブレーショングリッドの過露出部分にある正方形は赤色で強調表示されます。この場合、照明条件または露出設定を調整する必要があります。キャリブレーショングリッドの周囲にある太い緑色の枠は、両方のカメラ画像で正しく検出されたことを示しています。

手動キャリブレーションは、Stereo Calibration Toolを使用して実行できます。pylon 3D Viewerで、Tools > Stereo Calibration Toolをクリックしてツールを起動します。このツールには、キャリブレーションの各ステップに対応する異なるタブがあります。これらについては以下で詳しく説明します。

  • 初期設定
  • フォーカスの調整
  • キャリブレーションの検証
  • キャリブレーション
  • モノキャリブレーション
  • 計算
  • Save

初期設定#

キャリブレーション手順を開始するには、カメラとキャリブレーショングリッドを選択する必要があります。

  1. pylon 3D ViewerのToolsメニューで、Stereo Calibration Toolをクリックしてツールを起動します。
  2. Stereo Calibration ToolのFileメニューで、Connect Cameraをクリックします。
    Select Cameraダイアログが開きます。利用可能なカメラがそこに自動的に表示されます。
  3. 目的のカメラを選択します。
  4. Calibration Gridドロップダウンリストで、目的のキャリブレーショングリッドを選択します。
  5. OKをクリックします。

Stereo Calibration Tool - Select Cameraダイアログ

キャリブレーションの検証#

これで、現在のキャリブレーションを検証できます。一般的なキャリブレーションエラーは0.2ピクセル未満です。お使いのカメラで表示されるエラーがこの範囲内である場合は、キャリブレーション手順を終了できます。キャリブレーションエラーが大きい場合は、最適なカメラパフォーマンスを確保するためにキャリブレーション手順を続行してください。

検証を行うには、グリッドを両方のカメラの前にかざし、両方のカメラから同時に見えるようにします。グリッドが検出されるとすぐにキャリブレーションエラーが自動的に計算され、結果が画面に表示されます。

キャリブレーションを進めるには、Calibrateをクリックします。

Stereo Calibration Tool - 検証ステップ

情報

意味のあるキャリブレーションエラーを計算するには、グリッドをカメラにできるだけ近づけて保持する必要があります。グリッドがカメラ画像の小さなセクションしかカバーしていない場合、キャリブレーションエラーは、グリッドが画像全体をカバーしている場合よりも常に低くなります。このため、検証中の最小および最大のキャリブレーションエラーは、現在のグリッド位置でのキャリブレーションエラーに加えて表示されます。

キャリブレーション#

キャリブレーションを開始する前に、適切な Exposure Time を指定します。良好なキャリブレーション結果を得るには、画像が適切に露出されており、モーションブラーが発生しないようにする必要があります。したがって、シーンが適切に露出されるようにしながら、Exposure Time はできるだけ短くする必要があります。

完全なキャリブレーションは、各カメラを個別にキャリブレーションする作業(モノキャリブレーション)と、カメラ間の関係を決定するためのステレオキャリブレーションの実行で構成されます。ほとんどの場合、各カメラの内部キャリブレーションはそのまま維持されます。そのため、再キャリブレーション中、モノキャリブレーションはデフォルトでスキップされますが、Monocalibrationボタンをクリックして実行することもできます。

ステレオキャリブレーション中、両方のカメラはお互いにキャリブレーションされ、相対的な回転と平行移動が求められます。

まず、グリッドをカメラにできるだけ近づけ、非常に動かさないように保持する必要があります。両方の画像で完全に表示されている必要があり、カメラはグリッドを垂直に見る必要があります。グリッドがカメラの視線に対して垂直でない場合、グリッドのコーナーの予想される位置を指す小さな緑色の矢印がこれを示します。

Stereo Calibration Tool - キャリブレーションステップ

グリッドを非常に動かさないように保持する必要があります。モーションブラーが発生すると、グリッドは検出されません。画像上に描画されているすべてのグリッドセルは、キャリブレーショングリッドで覆われている必要があります。これは、カバーされているセルを緑色で塗りつぶすことで視覚化されます。

すべてのグリッドセルがカバーされると、それらは消え、単一の遠方のセルが視覚化されます。ここで、小さなセルがカバーされるように、グリッドをカメラからできるだけ遠くに保持する必要があります。グリッドがまだカメラに近すぎる場合は、矢印が示します。遠方のポーズでグリッドが正常に検出されると、セルが緑色で塗りつぶされ、結果を計算できます。

ステレオキャリブレーションで満足のいくキャリブレーションエラーが得られない場合は、まずモノキャリブレーションを実行してから、ステレオキャリブレーションを繰り返す必要があります。

モノキャリブレーション#

モノキャリブレーションは、各カメラ個別の内部キャリブレーションです。内部キャリブレーションは通常そのまま維持されるため、モノキャリブレーションはステレオキャリブレーションの結果が満足のいくものでない場合にのみ実行する必要があります。

モノキャリブレーションでは、グリッドを特定のポーズでカメラの前に保持する必要があります。緑色の領域を指すグリッドのコーナーにある矢印は、すべてのグリッドコーナーが緑色の領域の内側に配置されるべきであることを示しています。緑色の領域はセンシティブ領域と呼ばれます。「Size of Sensitive Area」スライダーでそのサイズを調整し、キャリブレーションを容易にすることができます。ただし、サイズを大きくしすぎると、キャリブレーション精度がわずかに低下する可能性があることに注意してください。

Stereo Calibration Tool - モノキャリブレーションステップ

モノキャリブレーションプロセスには、各カメラの5つのポーズが含まれます。グリッドのコーナーまたは辺がセンシティブ領域の上に配置されると、プロセスは自動的に次の必要なポーズを表示します。左カメラのプロセスが終了したら、同じ手順を右カメラでも繰り返します。

計算#

Calculateボタンをクリックすると、プロセスが終了し、最終的な結果が表示されます。示される結果は、すべてのキャリブレーションポイントの平均再投影誤差です。ピクセル単位で表され、通常は0.2未満の値になります。

Stereo Calibration Tool - 計算ステップ

Save#

今すぐSaveをクリックしてキャリブレーションを適用し、Stereo ace デバイスに保存します。