コンテンツにスキップ
ステージングサーバー
開発サーバー

pylon 3D Viewerの概要#

このトピックでは、blaze、Stereo ace、Stereo miniなどのBasler 3Dカメラをサポートするpylon 3D Viewerのユーザーインターフェイスの概要について説明します。

次のスクリーンショットは、pylon 3D Viewerのさまざまな要素を示しています。

pylon 3D Viewer ユーザーインターフェイス

アプリケーションレイアウトは、主に次の領域で構成されています。

  • メニューバー
  • 複数のツールバー
  • 左右のドッキング可能なペイン
  • 2Dおよび3Dサブウインドウを備えた画像ウインドウエリア
  • 下部にあるステータスバー

File Menu#

[File]メニューには次のコマンドがあります。

  • Save Depth and Image Data (Ctrl+S): 深度データと画像データ、およびカメラ設定をファイルに保存します。さまざまなフォーマットを利用できます。詳細については、Saving Depth and Image Dataを参照してください。
  • Exit (Ctrl+Q): pylon 3D Viewerを終了します。

View Menu#

Viewメニューを使用して、UI要素を表示または非表示にします。このメニューは動的に生成され、以下の切り替え項目が含まれます。

  • ツールバー(例:Camera Selector、File、Camera Control、Point Picking)
  • ペイン(例:Camera Features、Pixel Information、Documentation、Message Log、Depth Histogram、Depth Line Plot)

カメラメニュー#

[カメラ]メニューには次のコマンドがあります。

  • Rescan: 利用可能なカメラのリストを更新します。
  • Open (Ctrl+O): 選択したカメラを開きます。
  • Close (Ctrl+L): アクティブなカメラを閉じます。
  • Continuous Shot (F7): 連続取得を開始します。
  • Stop (F8): 画像取得を停止します。
  • Automatic Image Adjustment: カメラパラメータを自動的に設定し、深度レンジを調整します。この機能は、サポートされているカメラモデルおよび機能でのみ利用可能です。
  • Save Features: 現在のカメラProperty設定を.pfsファイルに保存します。保存する前に画像取得を停止する必要があります。
  • Load Features: 事前に保存した.pfsファイルからカメラProperty設定を読み込みます。

ツールメニュー#

Toolsメニューから、以下のコマンドにアクセスできます。カメラモデルやインストール環境によっては、すべての項目を利用できるとは限りません。

  • pylon IP Configurator: GigEデバイス用の外部IP設定ツールを起動します。
  • pylon GigE Optimizer: GigE Visionカメラ用のネットワーク最適化ダイアログを開きます。
  • Stereo Calibration Tool: 外部のステレオキャリブレーションツールを起動します。
  • Toggle Pick Mode (Alt+P): シングルポイントピッキングモードとデュアルポイントピッキングモードを切り替えます。

Window Menu#

Windowメニューを使用して、画像ウインドウを作成および配置します。

通常、メニューには以下のセクションが含まれます。

  • 2Dビュー
  • 3Dビュー
  • ウインドウの配置とナビゲーション

利用可能なコマンドは次のとおりです。

  • 新しいデプスマップビュー
  • 新しいコンフィデンスマップビュー
  • 新しい強度画像ビュー
  • 新しい点群ビュー
  • 近い
  • すべて閉じる
  • タイル表示
  • 重ねて表示
  • Next
  • 前へ

区切り線の下には、現在開いているサブウインドウの番号付きリストが表示されます。アクティブなサブウインドウにはマークが付いています。

Help Menu#

[ヘルプ] メニューからは、ドキュメントやサポート機能にアクセスできます。カメラモデルによっては、すべての項目を利用できるわけではありません。

  • pylon 3D Viewer ヘルプ (F1): ビューアーのマニュアルを開きます。機能が選択されている場合は、その機能に関するコンテキスト依存のヘルプが表示されます。
  • Basler 製品ドキュメント: 接続されているカメラの製品ドキュメントを開きます。
  • プログラマーズガイド: 接続されているカメラモデルのプログラマーズガイドを開きます。
  • サンプルディレクトリを開く: プログラミングサンプルが含まれているフォルダを開きます。
  • ソフトウェアアップデートの確認: ソフトウェアアップデート用の Basler ダウンロードページを開きます。
  • ファームウェアアップデートの確認: ファームウェアアップデート用の Basler ダウンロードページを開きます。
  • カメラファームウェアのアップデート: ブラウザでカメラのファームウェアアップデートページを開きます(サポートされているモデルのみ)。
  • DiagnosticInfo.tar.gz のダウンロード: カメラから診断パッケージをダウンロードします(サポートされているモデルのみ)。
  • リリースノートの表示: 利用可能な場合は、ローカルのリリースノートを開きます。
  • pylon 3D Viewer について: バージョンおよびライセンス情報が表示されたダイアログを開きます。

ツールバー#

Camera Selector Toolbar#

現在検出されているすべてのデバイスが表示されるカメラ選択ドロップダウンが含まれています。

File Toolbar#

デプスおよび画像データを保存するための [保存] ボタンが含まれています。

Camera Control Toolbar#

カメラコマンドへの素早いアクセスを提供します。

  • 開ける
  • 近い
  • Continuous Shot
  • 停止
  • 画像の自動調整

Point Picking Toolbar#

シングルポイントピッキングとデュアルポイントピッキングを切り替えるためのトグルピックモードを搭載しています。

ペイン#

Camera Features#

カメラ機能パネルには、 GenICam 選択したカメラの特徴ツリー。

典型的な使用例:

  • 機能カテゴリを展開および折りたたみます。
  • ドキュメントペインにコンテキストドキュメントを表示する機能を選択してください。
  • 機能ごとのヘルプを表示するには、++F1++キーを押してください。
  • 機能の読み取りと編集(取得中は編集が制限される場合があります)。

ピクセル情報#

ピクセル情報ペインには、選択した点の位置と深度に関連する値が表示されます。

単一点モードでは、ペインには選択した1つの点の値が表示されます。

デュアルポイントモードでは、ペインにはさらに両方のポイント間のデルタ値が表示されます(たとえば、 dX, dY, dZ)とユークリッド距離。

詳細については、 「イメージWindowsを参照してください。

Documentation#

ドキュメントペインには、カメラ機能ペインで選択した機能に関する状況に応じた情報が表示されます。

メッセージログ#

メッセージログペインには、アプリケーションメッセージが重要度と時刻情報とともに表示されます。例:

  • 情報
  • 警告
  • 重大

これは、接続、取得、および設定に関する問題のトラブルシューティングに役立ちます。

Depth Histogram#

深度ヒストグラムペインには、アクティブなシーンの現在の深度値の分​​布(ヒストグラム)が表示されます。

Depth Line Plot#

深度線プロットペインは、選択した2点間の線に沿った深度プロファイルを視覚化します(2点モード)。

オプションの「深度軸を反転」設定は、お好みの表示方法に応じて使用できます。

Image Window Area#

画像ウィンドウ領域には、2Dおよび3Dのサブウィンドウが含まれています。デフォルトでは、ビューアは標準的なウィンドウセットを開きます。

一般的なデフォルトビューは以下のとおりです。

  • 強度画像表示
  • 深度マップビュー
  • ポイントクラウドビュー

ウィンドウのレイアウトはカメラの種類ごとに保存されます。同じカメラファミリーを再接続すると、以前のレイアウトが復元されます。

すべてのペインは、Viewメニューからドッキング、ドッキング解除、非表示、復元を行うことができます。

表示#

Point Cloud View (3D)#

深度データを3D点群として表示します。

一般的なオプション:

  • カラー化モード
  • 軸を表示

カメラモデルとデータに応じて、次のようなカラー化を利用できます:

  • White
  • 輝度
  • Distance
  • Z Axis
  • Confidence Color
  • Intensity Color

Depth Map View (2D)#

レンジ/深度マップを2D画像として表示します。

一般的なオプション:

  • カラー化
  • 深度レンジスライダー

一般的なカラー化:

  • グレー
  • レインボー

Confidence Map View (2D)#

信頼性値をグレースケール画像として表示します。

Intensity Image View (2D)#

カメラの輝度または赤外線画像チャネルを表示します。利用可能なチャネルはカメラモデルによって異なります。

一般的なチャネル:

  • Intensity Left
  • Intensity Right
  • Intensity Combined
  • Infrared Left
  • 赤外線(右)

その他のビューア機能#

Point Picking#

ビューアは、2Dビューおよび3Dビューでのポイントピッキングをサポートしています。

  • シングルポイントモード:1つのポイントを選択してその値を確認します。
  • デュアルポイントモード:2つのポイントを選択して、値と距離を比較します。

ショートカット:

  • Alt+P:シングルポイント/デュアルポイントモードを切り替えます。
  • Alt+C:選択したポイントをクリアします。

画像の自動調整#

画像の自動調整 は、現在のシーンを分析し、接続されたカメラでサポートされている場合に適切な深度レンジ(DepthMin, DepthMax)を自動的に設定します。

ステータスバー#

ステータスバーには、次のような実行時情報が表示されます:

  • 現在のFPS
  • レイテンシ(モデル依存)
  • Frame ID
  • 接続 Quality インジケーター

Layout Persistence#

ビューアはウィンドウレイアウトを保存および復元します。

  • ペインの位置と表示状態
  • 2D/3Dビューを開き、その配置を設定します
  • ビュー固有の設定

レイアウトはカメラタイプごとに保存されるため、異なるカメラファミリ間での切り替えを素早く行うことができます。