コンテンツにスキップ
ステージングサーバー
開発サーバー

pylon Viewerの概要#

pylon Viewerは、グラフィカルユーザーインターフェースを使用して、ほとんどのカメラパラメーター設定を表示および変更するためのアプリケーションです。

pylon Viewerは、Basler pylon Software Suiteの一部です。Windows、Linux、およびmacOSで使用できます。

メインウィンドウ#

pylon Viewerのメインウィンドウ

File Menu#

Fileメニューを使用して、pylon Viewerの終了や現在画像の保存を行います。画像は次の形式で保存できます:

  • Bitmap
  • Tiff
  • jpg
  • png
  • raw
  • dng

View Menu#

[View]メニューには次のコマンドがあります。

  • Zoom In:画像を拡大します。
  • Zoom Out:画像をズームアウトします。
  • Zoom to Fit:画像を画像表示エリアに合わせます。
  • Zoom 100%:画像を元のサイズに戻します。
  • Full Screen:画像を全画面モードで表示します。
  • Tile: 画像ウィンドウのタブ形式のレイアウトをタイル表示に切り替えることができます。
  • Clear Message Log: [Message Log]ペインからすべてのメッセージをクリアします。
  • Show/Hide Crosshair:画像表示エリアの十字線を表示/非表示にします。
  • Show/Hide Grid:画像表示エリアのグリッドを表示/非表示にします。

カメラメニュー#

[Camera]メニューには、カメラを操作したり、カメラの設定を操作したり、自動的に検出されなかったGigEカメラを追加したりするためのコマンドがあります。

  • Open Device:デバイスを開き、使用できるようにします。
  • Close Device:デバイスを閉じます。
  • Single Shot:1枚の画像をキャプチャーします。
  • Continuous Shot:カメラが画像を連続的にキャプチャーするようにします。
  • Stop:画像のキャプチャーを停止するか、録画を停止します。
  • Pause:録画を一時停止します。
  • Record:ビデオを録画します。現在の設定で録画が開始されます。設定を変更する場合は、[Window]メニューから[Recording Settings]ペインを開きます。
  • Save Features:カメラ機能の現在の設定を.pfsファイルに保存します。拡張子「.pfs」は「pylon feature stream」を表します。
  • Load Features:以前に保存したカメラ機能の設定を含む.pfsファイルをロードします。拡張子「.pfs」は「pylon feature stream」を表します。
  • File Access: User Setsのアップロードやダウンロードなど、カメラのファイルシステムへのアクセスを提供します。
  • Copy Camera Features:すべてのカメラ機能の現在の設定をクリップボードにコピーします。これにより、別のコンテキストでそれらを使用できます。
  • Add Remote GigE Camera: IPアドレスを入力して、GigEカメラを追加します。これは、ネットワークに存在しないために自動的に検出されないカメラを追加する場合に役立ちます。
  • Automatic Image Adjustment:自動画像調整を実行します。
  • 静的Defect Pixel Correction:画素欠陥を補正します。
  • Vignetting Correction:画像から口径食アーティファクトを削除します。

ツールメニュー#

Toolsメニューからは、Optionsダイアログに加え、さまざまなツールにアクセスできます。

ツール

オプション

  • General:pylon Viewerをカスタマイズして、オンラインまたはオフラインバージョンのどちらのヘルプを使用するかを選択できます。
  • Language:pylon Viewer、pylon IP Configurator、pylon USB Configuratorの言語を変更できます。取得可能な言語は、簡体字中国語、英語、日本語、韓国語です。
  • Camera Emulation:pylon Viewerで使用できるカメラエミュレーションデバイスの数を指定できます。
  • Crosshair:十字線の外観を変更できます。
  • Grid:グリッドの外観を変更できます。

Workbenchメニュー#

[Workbench]メニューを使用すると、画像処理デザインを作成するためのレシピを作成および保存できます。

Window Menu#

Windowメニューでは、表示するペイン(DevicesペインやHistogramペインなど)を選択または選択解除できます。

Help Menu#

ヘルプメニューを使用して、pylonアプリケーションに関するフィードバックを送信したり、Baslerサポートに連絡したり、pylon Viewerに関する一般情報(バージョン情報やデータプライバシー情報など)を表示したりできます。Basler製品ドキュメント、pylonデプロイメントガイド、pylon SDKサンプルマニュアル、pylon APIドキュメント、C++ Data Processing Programmer's Guide、vToolライセンス情報の概要にもアクセスできます。

ツールバーボタン#

アイコン 機能
デバイスを開くアイコン 現在選択されているデバイスを開閉します。
保存アイコン 現在の画像を保存します。
シングル撮影アイコン 1枚の画像をキャプチャーします。
連続撮影アイコン 画像を連続的にキャプチャーします。
停止アイコン 画像のキャプチャーを停止し、または録画を停止します。
一時停止アイコン 録画を一時停止します。
録画アイコン 現在の設定で録画を開始します。設定を変更する場合は、[Window]メニューから[Recording Settings]ペインを開きます。
Zoom In Icon 画像を拡大します。
Zoom Out Icon 画像をズームアウトします。
Zoom to Fit Icon 画像を画像表示エリアに合わせます。
Zoom 100% Icon 画像を元のサイズに戻します。
Full Screen Icon 画像を全画面モードで表示します。
タイルモードアイコン 画像ウィンドウのタブ形式のレイアウトをタイル表示に切り替えることができます。
十字線アイコン 画像表示エリアの十字線を表示/非表示にします。
Grid Icon 画像表示エリアのグリッドを表示/非表示にします。
Histogram Icon [Histogram]ペインを開閉します。
シャープネスインジケーターアイコン [Sharpness Indicator]ペインを開閉します。
Automatic Image Adjustment Icon 現在の状況で良好な画像を取得するために必要なすべての設定をカメラが自動的に行うようにします。
Workbenchアイコン [Workbench]ペインを開閉します。

ペイン#

pylon Viewerには、デバイスの操作、デバイスと機能に関する情報の提供、およびpylonWorkbenchを使用した画像処理デザインの作成を行うためのさまざまなペインが用意されています。pylon Viewerのデフォルトレイアウトに含まれるペインを以下に示します。Workbench関連のペインの説明については、「Workbenchの概要」を参照してください。

Devices Pane#

Devicesペインには、コンピューターに接続されているすべてのカメラがインターフェースタイプ別にグループ化されてリスト表示されるデバイスツリーが表示されます。表示されるインターフェースは、pylon Software Suiteのインストール時に選択したオプションによって異なります。例として、上のスクリーンショットには、Basler boost、ace 2、pulse、aceカメラ、およびcamera emulationデバイスが表示されています。Show Cameras Onlyオプションを使用すると、インターフェース情報なしでカメラのみを表示できます。

このペインでは、新しく接続されたデバイスを定期的に自動スキャンするかどうかを選択することもできます。または、Refreshボタンをクリックして、デバイスツリーを手動で更新することもできます。

更新アイコン

Features Pane#

Featuresペインには、Devicesペインで選択されているカメラの機能が表示されます。デフォルトでは、次の2つのタブがあります。

  • Features – All:このペインには、現在選択されているカメラで使用可能なすべての機能が一覧表示されます。ここでは、頻繁に必要な機能や特定のタスクに必要な機能をグループ化することもできます。方法については、以下の「機能をグループ化するには」を参照してください。
  • Features – Basic:このタブには、カメラをすばやく設定するための機能のセットがまとめられています。

機能をグループ化するには:

  1. Edit Feature Tabsボタンをクリックします。
  2. Edit Feature Tabsダイアログで、新しいタブの名前を入力します。
  3. FeaturesペインからEdit Feature Tabsダイアログに目的の機能をドラッグします。
  4. 機能の追加が完了したら、[OK]をクリックします。

新しい機能タブがpylon Viewerに表示されます。他のタブと同じようにドッキングしたり、フローティング状態のままにしたりできます。新しいタブは、Windowメニューにも追加されます。

このカスタムタブは、すべてのカメラモデルで使用できます。つまり、ace 2カメラ用にタブを作成して、aceカメラで作業する場合に使用できます。これらのカメラモデルの機能セットは異なるため、aceモデルを使用している際は、ace 2で使用可能な機能は表示されません。これらの使用できない機能を表示するには、[使用できない機能を表示]チェックボックスをオンにします。

ユーザーが作成した機能タブは変更できます。機能の追加、機能の削除、タブの名前の変更が実行できます。Features – AllタブとFeatures – Basicタブは編集できません。

機能タブを編集するには:

  1. Edit Feature Tabsボタンをクリックします。
  2. Edit Feature Tabsダイアログで編集するタブを選択します。
  3. 必要な変更を行います。
  4. OKをクリックします。

Features – Allタブのもう1つの機能は、Common Tasksドロップダウンリストです。これは、解像度の変更や画質の最適化など、さまざまな共通タスクをすばやく完了できるように設計されています。いずれかのタスクを選択すると、関連する機能が機能ツリーで強調表示されます。

Pollingオプションを使用すると、定期的にカメラを自動ポーリングできます。または、Refreshボタンをクリックして、機能リストを手動で更新することもできます。

更新アイコン

Image Display Area#

カメラで撮影した画像やビデオがここに表示されます。現在開いているカメラごとに画像ウィンドウタブがあります。下部には、撮影している画像またはビデオに関する情報を提供するステータスバーがあります。カメラを配置する際は、視覚的な支援として十字線とグリッドを表示できます。

ツールバーのFull Screenボタンをクリックすると、画像を全画面モードで表示できます。

Full-screen Button

全画面表示の画像を2番目の画面に移動するには、画像上で右クリックし、Screen #2をクリックします。これにより、画像が2番目の画面に移動します。

Feature Documentation Pane#

Feature Documentationペインには、Featuresペインで現在選択されている機能に関する情報が表示されます。機能の説明は、さまざまな言語で取得できます。Languageドロップダウンリストから言語を選択します。

Feature Properties Pane#

Feature Propertiesペインには、Featuresペインで現在選択されているパラメーターに関する情報が表示されます。初期状態では、pylon Viewerの右側に最小化されドッキングされた状態で表示されます。

[メッセージログ]ペイン#

Message Logペインには、カメラの開閉や録画の開始など、pylon Viewerで実行された操作に関する情報が表示されます。情報、警告、重要の異なるメッセージレベルがあります。初期状態では、pylon Viewerの右側に最小化されドッキングされた状態で表示されます。

ペインの追加と削除#

Windowメニューから、表示するその他のペインを選択できます。デフォルトでは、一部はpylon Viewerの右側にドッキングされ、その他はフローティング状態になります。

ペインを閉じるには、そのタイトルバーを右クリックし、Closeをクリックします。

ペインの並べ替え#

ペインのドッキングを解除するには:

  1. ペインのタイトルバーをクリックし、配置したい場所までドラッグするか、フローティング状態のままにします。

ペインをドッキングするには:

  1. ペインのドラッグを開始します。
    位置決め支援が表示されます。
    位置決め支援
  2. マウスカーソルを使用して、ペインをドロップする場所をポイントします。
    目的のウィンドウ領域が青で強調表示されます。
  3. ペインをドロップします。

次のアニメーションで、このことを示します。

Animation of How to Rearrange Panes

これにより、pylon Viewerウィンドウを完全にカスタマイズし、必要に応じてペインを並べ替えることができます。

ペインを閉じるには、Windowメニューでそれらの選択を解除します。