コンテンツにスキップ
ステージングサーバー
開発サーバー

pylon 3D Viewerの概要#

このトピックでは、blaze、Stereo ace、Stereo miniなどのBasler 3Dカメラをサポートするpylon 3D Viewerのユーザーインターフェイスの概要について説明します。

次のスクリーンショットは、pylon 3D Viewerのさまざまな要素を示しています。

pylon 3D Viewer User Interface

アプリケーションのレイアウトは、主に次のエリアで構成されています。

  • メニューバー
  • 複数のツールバー
  • 左右のドッキング可能なペイン
  • 2Dおよび3Dサブウィンドウを備えた画像ウインドウ領域
  • 下部のステータスバー

File Menu#

[File]メニューには次のコマンドがあります。

  • Save Depth and Image Data (Ctrl+S): 深度データ、画像データ、およびカメラ設定をファイルに保存します。さまざまなフォーマットを利用できます。詳細については、Saving Depth and Image Dataを参照してください。
  • Exit (Ctrl+Q): pylon 3D Viewerを終了します。

View Menu#

Viewメニューを使用して、UI要素を表示または非表示にします。このメニューは動的に生成され、以下の項目を切り替えるトグルエントリが含まれています。

  • ツールバー(例:Camera Selector、File、Camera Control、Point Picking)
  • ペイン(例:Camera Features、Pixel Information、Documentation、Message Log、Depth Histogram、Depth Line Plot)

カメラメニュー#

[カメラ]メニューには次のコマンドがあります。

  • Rescan: 利用可能なカメラのリストを更新します。
  • Open (Ctrl+O): 選択したカメラを開きます。
  • Close (Ctrl+L): アクティブなカメラを閉じます。
  • Continuous Shot (F7): 連続取り込みを開始します。
  • Stop (F8): 画像取り込みを停止します。
  • Automatic Image Adjustment: カメラパラメータを自動的に設定し、深度レンジを調整します。この機能は、サポートされているカメラモデルおよび機能でのみ利用できます。
  • Save Features: 現在のカメラ機能設定を.pfsファイルに保存します。保存する前に、画像取り込みを停止する必要があります。
  • Load Features: 事前に保存した.pfsファイルからカメラ機能設定を読み込みます。

ツールメニュー#

Toolsメニューから、以下のコマンドにアクセスできます。カメラモデルやインストール状況によっては、すべての項目を利用できるとは限りません。

  • pylon IP Configurator: GigEデバイス用の外部IP設定ツールを起動します。
  • pylon GigE Optimizer: GigE Visionカメラのネットワーク最適化ダイアログを開きます。
  • Stereo Calibration Tool: 外部ステレオキャリブレーションツールを起動します。
  • Toggle Pick Mode (Alt+P): シングルポイントピッキングモードとデュアルポイントピッキングモードを切り替えます。

Window Menu#

Windowメニューを使用して、画像ウインドウを作成および配置します。

このメニューには通常、以下のセクションが含まれています。

  • 2Dビュー
  • 3D ビュー
  • ウィンドウの配置とナビゲーション

利用可能なコマンドは以下の通りです。

  • 新しい深度マップビュー
  • 新しい信頼度マップビュー
  • 新しい輝度画像ビュー
  • 新しい点群ビュー
  • クローズ
  • すべて閉じる
  • タイル状に並べる
  • 重ねて表示
  • Next
  • 前へ

区切り線の下には、現在開いているサブウィンドウの番号付きリストが表示されます。アクティブなサブウィンドウにはマークが付けられます。

Help Menu#

Help メニューから、ドキュメントやサポート機能にアクセスできます。カメラモデルによっては、すべての項目が利用できるわけではありません。

  • pylon 3D Viewer Help (F1): ビューアのマニュアルを開きます。機能が選択されている場合は、その機能に関するコンテキスト依存のヘルプが表示されます。
  • Basler Product Documentation: 接続されているカメラの製品マニュアルを開きます。
  • Programmer's Guide: 接続されているカメラモデルのプログラマーズガイドを開きます。
  • Open Samples Directory: プログラミングサンプルが含まれているフォルダを開きます。
  • Check for Software Updates: ソフトウェアアップデート用の Basler ダウンロードページを開きます。
  • ファームウェアアップデートの確認: ファームウェアアップデート用のBaslerダウンロードページを開きます。
  • Update Camera Firmware: ブラウザでカメラファームウェアのアップデートページを開きます(サポートされているモデルのみ)。
  • Download DiagnosticInfo.tar.gz: カメラから診断パッケージをダウンロードします(サポートされているモデルのみ)。
  • Show Release Notes: 利用可能な場合は、ローカルのリリースノートを開きます。
  • About pylon 3D Viewer: バージョン情報とライセンス情報が表示されたダイアログを開きます。

ツールバー#

カメラセレクターツールバー#

現在検出されているすべてのデバイスが表示されるカメラ選択ドロップダウンが含まれています。

ファイルツールバー#

深度データおよび画像データを保存するための Save ボタンが含まれています。

カメラコントロールツールバー#

カメラコマンドへのクイックアクセスを提供します。

  • オープン
  • クローズ
  • Continuous Shot
  • 停止
  • 画像の自動調整

ポイントピッキングツールバー#

シングルポイントとデュアルポイントのピッキングを切り替えるための Toggle Pick Modeが含まれています。

ペイン#

カメラ機能#

Camera Featuresペインには、選択したカメラのGenICam機能ツリーが表示されます。

一般的な使用方法:

  • 機能カテゴリを展開および折りたたみます。
  • 機能を選択して、Documentationペインにコンテキストドキュメントを表示します。
  • 機能固有のヘルプを表示するには、++F1++キーを押します。
  • 機能の読み取りと編集を行います(アクルージョン中は編集が制限される場合があります)。

ピクセル情報#

Pixel Informationペインには、ピックされたポイントの位置および深度関連の値が表示されます。

シングルポイントモードでは、選択した1つのポイントの値がペインに表示されます。

デュアルポイントモードでは、両方のポイント間のデルタ値(例: dX, dY, dZ)とユークリッド距離が追加で表示されます。

詳細については、Image Windowsを参照してください。

Documentation#

Documentationペインには、Camera Featuresペインで選択した機能のコンテキストに応じた情報が表示されます。

メッセージログ#

Message Logペインには、重要度や時間情報を含むアプリケーションメッセージが表示されます。例:

  • 情報
  • 警告
  • 重大

これは、接続、取り込み、および設定の問題のトラブルシューティングに役立ちます。

デプストグラム#

Depth Histogramペインには、アクティブシーンの現在の深度値の分布(ヒストグラム)が表示されます。

デプスラインプロット#

Depth Line Plotペインには、2つのピックされたポイント間のラインに沿った深度プロファイルが視覚化されます(デュアルポイントモード)。

希望する表示形式に応じて、オプションのInvert Depth Axis設定を使用できます。

Image Window Area#

画像ウィンドウ領域には、2Dおよび3Dのサブウィンドウが含まれています。デフォルトでは、ビューアは標準的な一連のウィンドウを開きます。

一般的なデフォルトビューは次のとおりです。

  • Intensity Image View
  • Depth Map View
  • Point Cloud View

ウィンドウレイアウトはカメラタイプごとに保存されます。同じカメラファミリを再接続すると、以前のレイアウトが復元されます。

すべてのペインは、Viewメニューからドッキング、ドッキング解除、非表示、復元を行うことができます。

ビュー#

点群ビュー (3D)#

深度データを3D点群として表示します。

共通オプション:

  • Colorization mode
  • Show Axes

カメラモデルやデータに応じて、以下のカラー化を利用できます:

  • White
  • 輝度
  • Distance
  • Z Axis
  • Confidence Color
  • Intensity Color

デプスプレビュー (2D)#

レンジ/デプスマップを2D画像として表示します。

共通オプション:

  • Colorization
  • Depth range slider

一般的なカラー化:

  • グレー
  • Rainbow

信頼度マップビュー (2D)#

信頼性値をグレースケール画像として表示します。

強度画像ビュー (2D)#

カメラの強度または赤外線画像チャネルを表示します。利用可能なチャネルはカメラモデルによって異なります。

一般的なチャネル:

  • Intensity Left
  • Intensity Right
  • Intensity Combined
  • Infrared Left
  • 赤外線ライト

その他のビューア機能#

ポイントピッキング#

ビューアは、2Dおよび3Dビューでのポイントピックをサポートしています。

  • シングルポイントモード:1つのポイントを選択してその値を確認します。
  • デュアルポイントモード:2つのポイントを選択して値と距離を比較します。

ショートカット:

  • Alt+P:シングルポイント/デュアルポイントモードを切り替えます。
  • Alt+C:選択したポイントをクリアします。

画像の自動調整#

画像の自動調整 は、現在のシーンを分析し、接続されたカメラがサポートしている場合に適切なデプスレンジ(DepthMin, DepthMax)を自動的に設定します。

ステータス バー#

ステータスバーには、次のようなランタイム情報が表示されます。

  • 現在のFPS
  • レイテンシ(モデルによって異なります)
  • フレームID
  • 接続Qualityインジケーター

レイアウトの永続化#

ビューアはウィンドウレイアウトを保存および復元します。

  • ペインの位置と表示/非表示
  • 2D/3Dビューのオープンと配置
  • ビュー固有の設定

レイアウトはカメラタイプごとに保存されるため、異なるカメラファミリー間での切り替えを素早く行うことができます。