コンテンツにスキップ

pylon Viewerの概要#

pylon Viewerは、グラフィカルユーザーインターフェースを使用して、ほとんどのカメラパラメーター設定を表示および変更するためのアプリケーションです。

pylon ViewerはBasler pylonカメラソフトウェアスイートの一部です。Windows、Linux、およびmacOSで使用できます。

メインウィンドウ#

pylon Viewerのメインウィンドウ

File Menu#

Fileメニューを使用してpylon Viewerを終了し、現在の画像を保存します。

View Menu#

Viewメニューには、次の選択項目があります。

  • Zoom In:画像を拡大するために使用します。
  • Zoom Out:画像を縮小するために使用します。
  • Zoom to Fit:画像を画像表示領域に合わせるために使用します。
  • Zoom 100%:画像を元のサイズに復元するために使用します。
  • Full Screen:画像を全画面表示モードで表示するために使用します。
  • Clear Message LogMessage Logペインからすべてのメッセージを消去するために使用します。
  • Show/Hide Crosshair:画像表示領域の十字線を表示または非表示するために使用します。
  • Show/Hide Grid:画像表示領域のグリッドを表示または非表示するために使用します。

カメラメニュー#

Cameraメニューには、次に示すカメラの操作、カメラ設定の操作、および自動検出されなかったGigEカメラの追加を実行するのための選択項目があります。

  • Open Deviceデバイスを開くために使用します。つまり、デバイスを使用可能にします。
  • Close Deviceデバイスを閉じるために使用します。
  • Single Shot:単一の画像を撮影するために使用します。
  • Continuous Shot:カメラで画像を連続撮影するために使用します。
  • Stop:画像の撮影を停止したり、録画を停止したりするために使用します。
  • Pause:録画を一時停止するために使用します。
  • Record:ビデオを録画するために使用します。現在の設定で録画が開始されます。設定を変更したい場合は、WindowメニューからRecording Settingsペインを開きます。
  • Save Features:カメラ機能の現在の設定を.pfsファイルに保存するために使用します。拡張子「.pfs」は「pylon feature stream」を意味します。
  • Load Features:以前に保存したカメラ機能の設定を含む.pfsファイルをロードするために使用します。拡張子「.pfs」は「pylon feature stream」を意味します。
  • File Access:ユーザーセットのアップロードやダウンロードなどのために、カメラのファイルシステムにアクセスするために使用します。
  • Copy Camera Features:すべてのカメラ機能の現在の設定をクリップボードにコピーするために使用します。これにより、別のコンテキストでも使用できます。
  • Add Remote GigE Camera:IPアドレスを入力することにより、GigEカメラを追加するために使用します。これは、ユーザーのネットワークに存在しないために自動的に検出されないカメラを追加する場合に役立ちます。
  • Automatic Image Adjustment自動画像調整を実行するために使用します。
  • Vignetting Correction:画像から口径食アーティファクトを取り除くために使用します。

ツールメニュー#

Toolsメニューからは、Optionsダイアログに加え、さまざまなツールにアクセスできます。

ツール

オプション

  • General:pylon Viewerをカスタマイズして、オンラインまたはオフラインバージョンのどちらのヘルプを使用するかを選択できます。
  • Language:pylon Viewer、pylon IP Configurator、pylon USB Configuratorの言語を変更できます。取得可能な言語は、簡体字中国語、英語、日本語、韓国語です。
  • Camera Emulation:pylon Viewerで使用できるカメラエミュレーションデバイスの数を指定できます。
  • Crosshair十字線の外観を変更できます。
  • Gridグリッドの外観を変更できます。

Window Menu#

Windowメニューでは、表示するペインDevicesペインやHistogramペインなど)を選択または選択解除できます。

Help Menu#

Helpメニューを使用して、pylonアプリケーションに関するフィードバックを送信したり、Baslerサポートに連絡したり、インストールされているプラグインなど、pylon Viewerに関する一般的な情報を表示したりします。ここから、Basler Product Documentation、pylon Deployment Guide、pylon SDK Samples Manual,、およびすべてのプログラマ向けガイド(SDKがインストールされている場合)にアクセスすることもできます。

ツールバーボタン#

  • デバイスを開く デバイスを開くアイコン: Click to open the device currently selected.
  • デバイスを閉じる デバイスを閉じるアイコン: Click to デバイスを閉じます currently selected.
  • 画像の保存 保存アイコン:クリックすると、現在の画像を保存します。
  • シングル撮影 シングル撮影アイコン:クリックすると、単一の画像を撮影します。
  • 連続撮影 連続撮影アイコン:クリックすると、カメラで画像を連続撮影します。
  • 録画 録画アイコン:現在の設定で録画が開始します。設定を変更する場合は、 録画設定 pane via the Window menu.
  • 一時停止 一時停止アイコン:クリックすると、 録画.
  • 停止 停止アイコン:クリックすると、画像の撮影を停止するか、録画を停止します。
  • Zoom In Zoom In Icon:クリックすると、画像を拡大します。
  • Zoom Out Zoom Out Icon:クリックすると、画像を縮小します。
  • Zoom to Fit Zoom to Fit Icon:クリックすると、画像を画像表示領域に合わせます。
  • Zoom 100% Zoom 100% Icon:クリックすると、画像を元のサイズに復元します。
  • 全画面表示 Full Screen Icon:クリックすると、画像を全画面モードで表示します。
  • 十字線の表示/非表示 十字線アイコン: Click to show or hide a 十字線 in the image display area.
  • グリッドの表示/非表示 Grid Icon: Click to show or hide a グリッド in the image display area.
  • ヒストグラム Histogram Icon: Click to open or close the ヒストグラム ペイン。
  • 鮮明度インジケーター シャープネスインジケーターアイコン: Click to open the 鮮明度インジケーター ペイン。
  • 画像の自動調整 Automatic Image Adjustment Icon: Click to let the camera automatically make all settings necessary to get a good image under current conditions.

ペイン#

pylon Viewerを初めて開くと、次のペインが表示されます。

Devices Pane#

Devicesペインにはデバイスツリーが表示されます。お使いのコンピューターに接続されているすべてのカメラが、インターフェースの種類別にグループで一覧表示されます。表示されるインターフェースは、pylon Camera Software Suiteのインストール時に選択したオプションによって異なります。例えば、上のスクリーンショットでは、Basler boost CXP-12カメラ、Basler ace 2 GigEカメラ、Basler pulse USBカメラ、Basler ace USBカメラ、およびカメラエミュレーションデバイスが表示されています。Show Cameras Onlyオプションを使用すると、カメラのみをインターフェース情報なしで表示できます。

In this pane, you can also select whether to auto-scan in regular intervals for recently connected devices. Alternatively, you can click the 更新 ボタン 更新アイコン to refresh the device tree manually.

Features Pane#

Featuresペインには、Devicesペインで選択されているカメラの機能が表示されます。デフォルトでは、次の2つのタブがあります。

  • Features – All:このペインには、現在選択されているカメラで使用可能なすべての機能が一覧表示されます。ここでは、頻繁に必要な機能や特定のタスクに必要な機能をグループ化することもできます。方法については、以下の「機能をグループ化するには」を参照してください。
  • Features – Basic:このタブには、カメラをすばやく設定するための機能のセットがまとめられています。

機能をグループ化するには:

  1. Edit Feature Tabsボタンをクリックします。
  2. Edit Feature Tabsダイアログで、新しいタブの名前を入力します。
  3. FeaturesペインからEdit Feature Tabsダイアログに目的の機能をドラッグします。
  4. 機能の追加が完了したら、[OK]をクリックします。

新しい機能タブがpylon Viewerに表示されます。他のタブと同じようにドッキングしたり、フローティング状態のままにしたりできます。新しいタブは、Windowメニューにも追加されます。

このカスタムタブは、すべてのカメラモデルで使用できます。つまり、ace 2 GigEカメラ用にタブを作成して、ace USBカメラで作業している際に使用できます。これらのカメラモデルの機能セットは異なるため、ace USBモデルを使用している際は、ace 2GigEで使用可能な機能は表示されません。これらの使用できない機能を表示するには、Show Unavailable Featuresチェックボックスをオンにします。

ユーザーが作成した機能タブは変更できます。機能の追加、機能の削除、タブの名前の変更が実行できます。Features – AllタブとFeatures – Basicタブは編集できません。

機能タブを編集するには:

  1. Edit Feature Tabsボタンをクリックします。
  2. Edit Feature Tabsダイアログで編集するタブを選択します。
  3. 必要な変更を行います。
  4. OKをクリックします。

Features – Allタブのもう1つの機能は、Common Tasksドロップダウンリストです。これは、解像度の変更や画質の最適化など、さまざまな共通タスクをすばやく完了できるように設計されています。いずれかのタスクを選択すると、関連する機能が機能ツリーで強調表示されます。

On this tab, you can also select whether to automatically poll the camera in regular intervals. Alternatively, you can click the 更新 ボタン 更新アイコン to refresh the features list manually.

Image Display Area#

カメラで撮影した画像や動画がここに表示されます。現在開いているカメラごとに画像ウィンドウタブがあります。下部には、キャプチャしている画像または記録しているビデオに関する情報を提供するステータスバーがあります。カメラを配置する場合、 十字線とグリッド as visual aids. Images can be displayed in full-screen mode by clicking the Full-screen Button button in the toolbar. To move the full-screen image to a second screen, right-click in the image and then click 画面#2画像が2番目の画面に移動します。

Feature Documentation Pane#

Feature Documentationペインには、Featuresペインで現在選択されている機能に関する情報が表示されます。機能の説明は、さまざまな言語で取得できます。Languageドロップダウンリストから言語を選択します。

Feature Properties Pane#

Feature Propertiesペインには、Featuresペインで現在選択されているパラメーターに関する情報が表示されます。初期状態では、pylon Viewerの右側に最小化されドッキングされた状態で表示されます。

[メッセージログ]ペイン#

Message Logペインには、カメラの開閉や録画の開始など、pylon Viewerで実行された操作に関する情報が表示されます。情報、警告、重要の異なるメッセージレベルがあります。初期状態では、pylon Viewerの右側に最小化されドッキングされた状態で表示されます。

Adding Panes#

Windowメニューから、表示するその他のペインを選択できます。デフォルトでは、一部はpylon Viewerの右側にドッキングされ、その他はフローティング状態になります。

ペインの並べ替え#

メインウィンドウのすべてのペインには、ペインを閉じたり、pylon Viewerウィンドウからドッキング解除したりするためのボタンがあります。ペインがドッキング解除されている場合は、デスクトップ上で自由に移動できます。もう一度ドッキングする場合は、次の手順に従います。

  1. ペインのドラッグを開始します。
    位置決め支援が表示されます。
    位置決め支援
  2. マウスカーソルを使用して、ペインをドロップする場所をポイントします。
    目的のウィンドウ領域が青で強調表示されます。
  3. ペインをドロップします。

次のアニメーションで、このことを示します。

Animation of How to Rearrange Panes

これにより、pylon Viewerウィンドウを完全にカスタマイズし、必要に応じてペインを並べ替えることができます。